BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,817 Posts
Discussion Starter #1
Hi All,

I've got a 2005 530i with 160k miles on the odo. I'm having issues with the fan speed on the climate control. The fan will only blow fast if I hit max AC or when I turn on the front defroster, turning up the knob manually does not increase the fan speed and I get very little heat. I'm getting codes 9C7B AUC Sensor and 9C55 related to climate control. Any ideas? It's very annoying.
 

·
Registered
Joined
·
1,944 Posts
One of the symptoms of a failing battery is the heater fan will not operate manually. MAX and defrosters will run the fan full speed but you can't manually adjust very high

No harm in giving the battery a full charge and seeing what happens
 

·
Registered
Joined
·
1,817 Posts
Discussion Starter #3
One of the symptoms of a failing battery is the heater fan will not operate manually. MAX and defrosters will run the fan full speed but you can't manually adjust very high

No harm in giving the battery a full charge and seeing what happens
Interesting. I get the battery warning on my dash after I turn off the car but leave the ignition on for a moment. Could be battery going bad, just an AGM battery from auto store will work, correct?
 

·
Registered
Joined
·
1,944 Posts
Interesting. I get the battery warning on my dash after I turn off the car but leave the ignition on for a moment. Could be battery going bad, just an AGM battery from auto store will work, correct?
yep - they all seem to have the right battery. just match the rating, H8 AGM battery

You will know right away if it helps. You will want to get the battery registered at some point. It tells the charging system to charge the battery properly for a new battery and the charging profile changes as it ages.
 
1 - 4 of 4 Posts
Top