Bimmerfest BMW banner

1 - 3 of 3 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1 (Edited)
Climate control system KLIMA fault

So i did something regrettable which was driving around when i had temporarily disconnected the IHKA climate control system. Why i did this is another story. Anyway when i put everything back together again and reconnected it i came up with a code fault for every sub system for the module. I tried clearing codes, resetting module, and disconnecting battery to reset but nothing seems to work. The AC doesn't work anymore, and it seems like some components within climate control are no longer working. I.e heat exchanges, fan control, stratification.

Is there a specific reinitialization sequence to get the climate control working again?

The code faults are:

KLIMA 9C70: ISupply,SZM
KLIMA E708:
KLIMA 9C59: IEvaporator termperature sensor
KLIMA 9C5A: IHeating heat-exchanger sensor, left
KLIMA 9C5C: IHeating heat-exchanger sensor, right
KLIMA 9C60: ISZM button 1
KLIMA 9C61: ISZM button 2
KLIMA 9C62: ISZM button 3
KLIMA 9C63: ISZM button 4
KLIMA 9C65: ISZM variant coding 2
 

·
Registered
Joined
·
58 Posts
Discussion Starter #2
Resolved:

I went back and check everything and found that a connector wasn't connected properly in the IHKA module. What I discovered (I'm guessing here) is that the Heater control valves did not operate which caused the engine to overheat and begin detonating.

Anyway I plugged in the loose harness and everything went back to normal, detonation immediately stopped.
 

·
Resident Curmudgeon
Joined
·
22,804 Posts
1 - 3 of 3 Posts
Top