BimmerFest BMW Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Gas out of my cold start comes as a stream and I think, in reading the book it should come out as a mist. HELP. Car also sometimes especially after re-start runs really poor and belches blus smoke and seems to run really rich... Also does the Thermo-Time switch have any bearing on any of this?
 

·
another E30 nut
Joined
·
916 Posts
The cold start is made to put a large amount into the intake. However a stream sounds odd. The tips on the end dont look to be designed for atomization so it may be normal.
Theres several things that would cause it to run poor and rich. However 2 are the most common.
1. ICV check to make sure its cleaned and working properly
2. AFM Sometimes they give up the ghost for no reason or they stick from built up crud and varnish.
My recommendation is to clean both ICV and AFM and free them of any foreign matter.
And while you are at it the Intake butterfly and TPS

Good Luck!!
 

·
Rather Large Member
Joined
·
4,553 Posts
Could you just bypass the CSV? He's in Florida after all.........I'm unfamiliar with the whole thing, never having had one. It seems like it's stuck in the open position, if gas is running out, I've seen injectors do that.
 

·
another E30 nut
Joined
·
916 Posts
just remove the wire that fires it. Sounds like its working properly. The thing to check would be how long its staying on.
 

·
Rather Large Member
Joined
·
4,553 Posts
I just re-read his post. I'm gonna revise my statement and say it's probably clogged, or gummed up. I still think It'd be ok in Florida to just run without it though.
 

·
Rather Large Member
Joined
·
4,553 Posts
Probably so, but wouldn't be wasting the extra gas............
 
1 - 9 of 9 Posts
Top