BimmerFest BMW Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey guys,

Sort of a rough first post to a forum I know. I have been around many other BMW forums just not this one for the last few years.

I finally found my unicorn and picked it up last week. It is a 2008 650i Convertible 6sp Manual. Everything seemed flawless on the car, I just came from an e61 and fell in love with the 6 immediately.

Took it out for an evening cruise last night and when I got home went to close the top, everything went to schedule until right before it closed. It refused to latch and started grinding pretty bad right above the steering wheel. Since it was so close, I began to try the manual closing technique described in the users manual. I could get the top seated to the windshield, but the manual lock would not engage when turning the allen key. Just made the clicking noise a little quieter. The car is in the garage, but I would really like to at least be able to lock the top before moving it to a shop or dealer.

I spent a few hours today reading threads on this forum and couldn't seem to find any thread about this exact issue. I attached a picture of it sitting just above the windshield. If anyone knows how to pop the plastic cover off the front part of the top I am sure I could at least look in and see what wasnt working.

Any help is greatly appreciated.

Mark

_a2_
 

·
Registered
Joined
·
1,287 Posts
Once in a while (maybe one out of ten or twenty top closings) my top stops at that close point and the locks won't come out,engage and cinch down. I just reverse it and open it back up about halfway through the cycle and then try to close it again. It typically then finishes closing normally. Not sure as to the cause but it only happens intermittently.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Unfortunately the top won't move in any direction electronically. Just makes a grinding noise right above the drivers side sun visor right where that picture was taken. Trying to lock it using the manual lock with the Allen wrench just makes a clicking noise in the same location and won't engage the locks either.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Talked with a service tech at the local BMW dealer today. He said that this happens when the gear on the drive shaft fails. Typically a $4-500 repair I was told. Taking it in tomorrow AM. We will see!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Appreciate the advice guys! Issue was the tension cords near the top, 2 popped off, when reattached they popped off again. $445 for parts and labor at the stealership to replace and the car is back to good. Time to start on the mods!
 

·
Registered
Joined
·
422 Posts
I had this happen once. The rod/wire that connects the hook to the motor broke. I bought a new part and fixed it myself. The total cost was under $40 and didn't take me long to fix it.

I have attached a photo of the part that broke. You can see at the end where it came apart.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #8
I had this happen once. The rod/wire that connects the hook to the motor broke. I bought a new part and fixed it myself. The total cost was under $40 and didn't take me long to fix it.

I have attached a photo of the part that broke. You can see at the end where it came apart.
Thank you for the advice for next time. I am slowly learning knowledge on this chassis. :thumbup:
 

·
Registered
Joined
·
60 Posts
i had this happen once. The rod/wire that connects the hook to the motor broke. I bought a new part and fixed it myself. The total cost was under $40 and didn't take me long to fix it.

I have attached a photo of the part that broke. You can see at the end where it came apart.
whats the name of this wire im trying to look for it online
 
1 - 11 of 11 Posts
Top