BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,144 Posts
Discussion Starter · #1 ·
Hey guys..... Its kind of a long story but i'll cut it short. Wednesday afterschool i was going home from school when i saw my temp meter shoot up. so I instantly pulled into chevron and called my dad cause i was worried my water hose broke since im getting close to 100,000 miles. it turns out i was extremely low on coolant. so i just filled it with water and drove home. everything was good and friday in the morning i decided to check it again and it seemed to be normal so i said ok cool. friday after school i went to my friends house and decided to check it again and sure enough it had gone down a good inch.....

So I called my dad and he said its probably just the cap. ITs not on tight and the water is evaporating and he was rigth the cap wasnt screwed on 100%. I checked it again like 20 minutes ago and i was about 3 or 4 inches below the line! and the cap was on tight i made sure..

So my dad comes we fill the coolant tank with coolant and we kept pouring it in and pouring it in maybe like a freaking gallon or something and in the meentime i was looking under the car but there was nothing dripping from under the car. So we ran the car for about 5 - 10 minutes and on the right side of the car undernearth ( when u look at the car from the front on the right side, not the right side from inside the car) and there was a leak. My dad said we'll take a look at it tommorow but does anyone have any ideas? is it my water hose or wat?
 

·
I Am The Machine
Joined
·
20,931 Posts
Hey dude, got your text, sorry I never got a chance to reply.

Anyway, how far back or forward in your engine is the leak? If you can pinpoint the hose thats leaking, that would be good. A hose is the best case scenario, and it sounds like you got lucky here and that is all it is. At least its not your radiator or water pump!

If the leak was towards the rear of the engine bay, could be a return hose from your heater core or something like that. If its right up close to the front, it could be a hose connecting to your radiator. Really, it shouldn't be that hard to fix. At least it didn't just suddenly rupture. In the Supra I was just sittin' at a light blasting music with the top off and lookin' cool, and all the sudden the entire car is just covered in steam. Like, instantly. It was just this big eruption and steam was pouring from the hood going everywhere, all inside the car and everything :rofl:. It seriously scared the sh!t outta me. Damn coolant hose just decided to completely explode for no reason and sprayed coolant all over the block.....lol.
 

·
Registered
Joined
·
1,144 Posts
Discussion Starter · #4 ·
I was just sittin' at a light blasting music with the top off and lookin' cool
lmaoooooooooooooooo oh man thats funny hahahaha. but ya dude its near the front were gonna go take a look at it today. its like really close to the front of the engine so i just gotta go look under the car and take care of it lol
 

·
Registered
Joined
·
120 Posts
In the Supra I was just sittin' at a light blasting music with the top off and lookin' cool, and all the sudden the entire car is just covered in steam. Like, instantly. It was just this big eruption and steam was pouring from the hood going everywhere, all inside the car and everything
wow haha that's hilarious! sure it wasn't at the time. I probably would have flipped out :rofl:
 

·
Registered
Joined
·
25 Posts
i had a similar problem i was pushing the car on the highway and when i can home coolant was coming from the top of the expansion tank so i refilled it withcoolant and bought a new cap and tightened it real good what do you guys think caused all the pressure build up in the expansion tank to cause it to spit out a whole gallon of coolant???? sorry for the thread hack by the way :D
 

·
Registered
Joined
·
1,144 Posts
Discussion Starter · #7 ·
lol its cool man. i duno why it happened but just make sure u get it fixed its really annoying lol.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top