Bimmerfest BMW banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Have a 2006 X5 with 136k miles. My cruise control turns on, but will not engage. The fuse is good is there any other common problems or issues I could look at next. I have no lights other than the cruise light when I try to engage it.
 

·
Nuclear engineer
02/2012 X5 35d M57Y CPO 99K miles NOKIAN WR G3 12K miles
Joined
·
17,468 Posts
Has to be >20 MPH
 

·
Registered
Joined
·
830 Posts
Have a 2006 X5 with 136k miles. My cruise control turns on, but will not engage. The fuse is good is there any other common problems or issues I could look at next. I have no lights other than the cruise light when I try to engage it.
You have to push the + button to engage it. The on off button only turns it on and off. The top button reengages the speed you've set after braking disengages it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Have a 2006 X5 with 136k miles. My cruise control turns on, but will not engage. The fuse is good is there any other common problems or issues I could look at next. I have no lights other than the cruise light when I try to engage it.
You have to push the + button to engage it. The on off button only turns it on and off. The top button reengages the speed you've set after braking disengages it.
I understand how the system works, but it's not engaging. I'm turning on the cruise system and the light comes on, I hit the + at highway speeds of 50-75mph and it won't engage to hold at that speed.
 
1 - 5 of 5 Posts
Top