BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all,

I haven't been able to find a thread about this, but maybe I'm just blind :) I have a problem with my X3 F25 (40k km). The other day, the ABS, 4x4 and handbrake lights all lit up together. I ran a few kilometres, very slowly, to go home and then left it there. The next day I had to use to car again and it all went fine, same goes for a couple of other times after that. Since I have been feeling for a while a sort of tug in acceleration in first gear, I called the dealership to ask about it and he told me that it could be the transfer case actuator or at least the oil in it. But he said that since there are no warning lights on at the moment, running diagnostics first could be a waste of money because nothing might emerge.

So, my questions after this long preamble are if you have any experience about this sort of problem and how I can run diagnostics at home, so that I can save some money (and perhaps get it fixed by a friend rather than dealership). I already have the Enet cable and Esys program because I checked some things last year, but I'm still pretty much a newbie.

Thanks a lot for your help as always!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Let me a bit more precise. I did find some posts about this problem, but none of them were about the F25, but rather about the E83 and I'm not sure how much they differ. And any help on how to run full diagnostics with cheat sheet for error codes is more than welcome.

Cheers!
 

·
Nuclear engineer
02/2012 X5 35d M57Y CPO 100K miles NOKIAN WR G3 20K miles
Joined
·
18,367 Posts
Unexplained collections of warning lights often indicate a failing battery.

A BMW will not fully charge its battery. For best battery performance the owner must frequently and regularly charge with BMW's recommended battery CHARGER.
 

·
Registered
Joined
·
1 Posts
Lastweek 7pm I startup the car normally and move out from half of my parking place suddenly engine stop and like you abs handbrake engine light all on. then wont start again but wait few mins funny things happen can start again but idle 5-10sec then engine cut off again, I tow back to BMW dealer but next day morning they told me start car normal with no light on. then they run the diagnostics and only find a low voltage code. Service guy also told me all module in car are all link together if it sense low voltage will cut out all connection for safely.
They guess issue cause by my aftermarket 24hours car cam (already use it 7months), I go get back my car and set the car cam cut off voltage from11.8V to 12.3V. One day after happens again I try uninstall all car cam power cable from fuse box but no help then no choice tow the car back to dealer again at night, Next day morning I call them at 8:30am the guy told me the car start normally again with no light on... today they told me need wait tomorrow afternoon to run check again and also check the battery health.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hi, i see that your issue might very different from mine. Anyway, at the end, I brought the car to a BMW dealer telling them the problem and that I can feel a tug in acceleration in first gear especially. Right away they told me it could the oil in the transfer case actuator. Apparently they have run the diagnostics and found nothing, but checked the oil and it was denser than supposed to be. They changed that and told me that I will have to check how it feels and what happens for the next 100 kms. It already feels better but I will keep you updated. Also, about running diagnostics by myself, I have decided to buy Carly, both the tool and the app (not too expensive). Is that as useful as it seems?
 

·
Registered
Joined
·
43 Posts
f25 4x4 warning message

hello guys, i am having the same issue with my 2012 F25 X3.. i will update you guys as we go. thank you for sharing your issues and solution..
 
1 - 6 of 6 Posts
Top