BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
888 Posts
Discussion Starter · #1 ·
So, I went to AAMCO transmission in Athens, Ga and had them do a new torque converter, solenoid, fluid, and filter change.

Well, before that, I had this SES light on P0741 - torque converter stuck off

anyways, after I got the car back, I can't really tell if they put in a torque converter or just turn off the engine light.

Only thing different is now i don't have SES light on and service engine indicator cannot be toggled through my push button. it used to be temperature, gas mileage, how far i can go, time, and mileage til the next service.

well, now, I don't see the "mileage til the next service" but everything else is there.

So, I am thinking... maybe they did something to the computer and not fixed the whole car itself.
 

·
Format c:\*.* /y
Joined
·
1,321 Posts
My '01 doesn't have mileage til service as an option to toggle through, it just appears for a few seconds when the ignition is first turned on...
 

·
Registered
Joined
·
5 Posts
I don't know if our cars have these but most have an inspection cover on the bellhousing, pull that off and see if the tc looks new or not.
 

·
Ubergeek
Joined
·
15,646 Posts
My '01 doesn't have mileage til service as an option to toggle through, it just appears for a few seconds when the ignition is first turned on...
+1... Latoilette, you were never able to find the miles-to-service by pressing the BC button.
 
1 - 5 of 5 Posts
Top