BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Who u r, u r forever....
Joined
·
527 Posts
Discussion Starter · #1 ·
My i-Drive display keeps blinking after start up and and continues to blink until i drive for about 15 minutes, then it seems to be fine..... I have ruled out a bad battery, i just installed a new one from the dealer. Have had my car NOT start a few times over the past several weeks also, with old and new battery. Car is basically driven to work and home daily, 25miles each way. Was wondering if the battery is not having enough time to charge properly. Anyone experiencing this type of problem???

Thanks
 

·
Registered
Joined
·
31 Posts
Had the same problem with my 6 series. First they replaced the battery (did not solve the problem), then they replaced one of the computers (did not resolve the problem), I picked it up from the dealer today and was told that the amplifier was shorted due to the logic 7 or something like that so they replaced the amplifier, ill let you know if that resolves the problem. Long story short thank god for warranty lol
 

·
Registered
Joined
·
560 Posts
Hi Desert BMW battery issues

Well people I have the same problem, u got to search the forum deeper, but theres one section that speaks to where bmw says something like u have to drive your car so many miles a day/week whatever to get the system to charge. In fact its from their HQ they say if u don't drive it enough it wont charge properly. May want to look in the search folder, type in battery. Don't really matter what series, even though schematics may be different, same fundamental workings. Bmw's are very sensitive, electronically and coolant systems also. I'd make sure all your fuses are good too.
 

·
Who u r, u r forever....
Joined
·
527 Posts
Discussion Starter · #4 · (Edited)
thanks for your input.....this is like my 7th Bimmer, you would think i had learned my lesson by now!!!!! :rofl:

I did disconnect the battery for about 4 hours last nite, (actually forgot it was disconnected), has not blinked since that event!!!
 
1 - 4 of 4 Posts
Top