BimmerFest BMW Forum banner

Distortion from IPOD - ICELINK set up...Any suggestions??

1028 Views 7 Replies 3 Participants Last post by  [email protected]
Howdy,
first let me begin by saying that [email protected] did an AWESOME job installing my ICELINK on my X5 !

I was in and out of his shop within an Hour..Tom's a class act :thumbup: .

Keep in mind that my installation was a little more complicated than most because I have a Navigation System.
I called 3 BMW dealers trying to schedule an appointment to have my IPOD hardwired to my Factory head unit and all three dealers told me that It couldn't be done with the Nav System.

Anybody that lives in So Cal you really owe it to yourself to call TOM and get on his calender for an installation.

My only issue is the quality of sound from my IPOD..It's not even close to the clarity of my previous CD set up.

Even at low volume some songs have distortion..Is there something I can do to improve the sound quality ?? Is there a setting option on my IPOD that I can adjust to improve the sound?

Thanks for the Input !

Jeff
1 - 8 of 8 Posts
When Tom installed my IceLink setup on Saturday, we noticed some distortion in the bass...he lowered the output of the iPod (using the Dension UI while plugged in) to 2V.

After he left, I still noticed some distortion, so I lowered it to 1V. It's sounded great since.
Drew, How do I lower the setting to 1V ??Do i need to have Tom do it or can I do it myself ?

J
While you have your iPod plugged into the IceLink, there's a menu setting for the output level...can't tell you where it is off the top of my head (it's a menu layer or two down), but I believe the information is in the documentation...I was able to find it myself rather easily.
Thanks Drew ! I'll review the manual and give it a try.

Cheers

J
DrewM said:
While you have your iPod plugged into the IceLink, there's a menu setting for the output level...can't tell you where it is off the top of my head (it's a menu layer or two down), but I believe the information is in the documentation...I was able to find it myself rather easily.
Drew your the man ! I lowered my IPOD to 1V and it sounds great now :thumbup:

Thanks

Jeff
DrewM said:
When Tom installed my IceLink setup on Saturday, we noticed some distortion in the bass...he lowered the output of the iPod (using the Dension UI while plugged in) to 2V.

After he left, I still noticed some distortion, so I lowered it to 1V. It's sounded great since.
Excellent...I get one right once in a while. Glad it helped.
TTVIPER said:
Drew your the man ! I lowered my IPOD to 1V and it sounds great now :thumbup:

Thanks

Jeff
Thanks for the props - glad you like the ice>Link Plus! :thumbup:

Depending on the BMW - sometimes the gain setting can be a little high to taste. I usually keep the following settings, 2v seems to be the best in my opinion - but some vehicles may vary.

Feel free to contact me directly or post here in the thread if you have any further questions!
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top