BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Skjoni's Dad
Joined
·
1,733 Posts
Discussion Starter · #1 ·
I logged on to my owner's circle, and after updating my password, checked out my pending ED car. It was listed as a red 2008 135i coupe! When I put in my production number, my sapphire black 335i sedan appeared, but the 135i was still there! Is this a stupid marketing scheme? Anyone else have a 1-series appear in their oc? There's no way this was entered by myself or my CA!
 

·
Registered
Joined
·
868 Posts
Yes, I had the same thing. I put in my production #, got my car added, then deleted the red 128i I had. I called BMW and they said since they upgraded the site this past weekend everything has been screwy.
 

·
*insert witty one liner*
Joined
·
257 Posts
I had this problem too. However, as soon as my car got a VIN number all the correct information was shown. No issues since I got my VIN #. Before I got that, it said I had ordered a 5 series, 3 series, 128i convertible, and a red 135i lol
 

·
Registered
Joined
·
152 Posts
Same issue here....a new vehicle everytime I went in. X6, M3, 335 but not the 135i I had ordered on ED. When putting my production number in I then saw a titanium silver 135i instead of the black saphirre I had ordered. My CA verified everything was ok and I was indeed still picking up a black sapphire on June 6th! I emailed bmw and a week or so ago and have heard absolutely nothing back. I assumed like mentioned above it was their web site merger that created the issue.
 

·
*insert witty one liner*
Joined
·
257 Posts
Cool, another person from Central Florida getting a 135i. It sucks that you pick up your car the same day I fly back to Orlando.
 

·
Registered
Joined
·
202 Posts
Same thing here also and could not locate the status graphic.
 

·
Registered
Joined
·
149 Posts
I logged on to my owner's circle, and after updating my password, checked out my pending ED car. It was listed as a red 2008 135i coupe! When I put in my production number, my sapphire black 335i sedan appeared, but the 135i was still there! Is this a stupid marketing scheme? Anyone else have a 1-series appear in their oc? There's no way this was entered by myself or my CA!
For me though, when I put my production #, a 335i (forget the color now) came up. It was only later on when I got the VIN #, the right 535i Black Sapphire/Black came up.

I think this has more to do with the website not being updated with the latest data fast enough.
 
1 - 7 of 7 Posts
Top