Bimmerfest BMW banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,716 Posts
Discussion Starter #1
Does your nav screen flash lines across the monitor when powering the unit on and off? Mine does it just for a second. Looks abnormal to me.
 

·
Registered
Joined
·
1,716 Posts
Discussion Starter #4
sidneyj said:
Does your nav screen flash lines across the monitor when powering the unit on and off? Mine does it just for a second. Looks abnormal to me.
Only 2 people with Nav? :confused:
 

·
Oscar
Joined
·
650 Posts
Mine doesn't but maybe I have just never noticed
 

·
Registered
Joined
·
954 Posts
sidneyj said:
Does your nav screen flash lines across the monitor when powering the unit on and off? Mine does it just for a second. Looks abnormal to me.
Absolutely not. Something is definitely wrong.










































HA! That's to get you back for that phone call after we parted ways!
 

·
Registered
Joined
·
1,716 Posts
Discussion Starter #8
Tyrone said:
Absolutely not. Something is definitely wrong.
HA! That's to get you back for that phone call after we parted ways!
It seems like the consensus is that there is a problem with the nav. I had this dude from SoCal......some young kid trying to make it through college install it for me. He told me he had done this sort of thing a dozen times but I think I got taken to the cleaners. He broke my wood trim, broke my drivers seat, had a couple dozen extra bolts left over, ruined my battery, broke my BM54 radio and it would not work with Sirius, forgot to hook up my cd changer then backed into my brothers mailbox totally destroying it. Then he ate all the pizza I ordered and stole all my clothes I was going donate to the homeless. ;) It's really hard to find good help in this world. :rofl:
 

·
Registered
Joined
·
954 Posts
Yeah, I'm just glad you called upon me in the end to rectify the situation! So what ever became of that mailbox?
 
1 - 9 of 9 Posts
Top