BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter · #1 ·
So my wife is driving my 550i for the very first time on the way to the dealer to drop it off for M Aero Kit install. We are making a nice easy turn to the right at an intersection doing all of about 20 MPH, when under the iDrive map comes a warning that says, "Drive system control off. Drive moderately!". Then BRAKE in orange comes on in center of dash display along with orange circle with triangle warning sign. Everything seems to be working fine, No DSC or other warning lights. We get to the dealer, shut the car off. Explain to the the SA what happened and he re-starts the car and no warning message or any immediate sign of a problme appears. Says they will check for faults while they have the car.

Sure hope it is not the dreaded Steering Angle Sensor issue!!

Anybody see anything similar happen and have an explanantion?
 

·
Registered
Joined
·
184 Posts
It is. :( have it replaced and put it behind you(at least for another few thousand miles). :(
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #3 ·
Yeah, it was confirmed by SA today. Hope he can find an SZL module quickly someplace. I am just getting my M Aero Tech Kit installed and Style 166M wheels waiting at home for install, and now I have to wait for this SZL thing. Once that is installed it is still another day or two for the dealer to re-boot and/or upgrade CIP (or whatever it is actually called this month!)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top