BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I been having an issue with my 2013 528i, my engine went bad so i dropped a Used engine, everytime i drive it for more than 20 min or go on the highway the car send out this message ***8220;DRIVETRAIN MALFUCTION***8221; and the car loses power, also if i turn it off it wont turn back on, i have to let it cool off for about 30 min. No check engine light comes on. I been with out a car for 3 months now and i am in need of some help please. I change spark plugs, and high pressure fuel pump since the mechanics computer was giving him a default message. PLEASE HELP!!!
 

·
Munich Mark - 2014 535XD
Joined
·
832 Posts
Without an exact readout of all the current codes I doubt anyone here can help other than to ask you for that... If there really are no codes at all I wonder what OBC Reader he’s using... then it’s indefinite Dart Board hit and miss.

There’s about 20 different things it can be, mainly and obviously somehow temp related like Water Pump, Thermostat, Sensors, etc... Could just be a simple broken wire or connector somewhere after all the work done which sounds like it already costs $ thousands without resolution.

Time for a 2nd Mechanics opinion ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
You might be right, and yes i have already spend so much money, now my mechanic is telling me that he will take it to someone else that has all the different types of BMW programs that will diagnose the issue. Hopefully that will take care of it. Thanks again.
 

·
Registered
Joined
·
346 Posts
You might be right, and yes i have already spend so much money, now my mechanic is telling me that he will take it to someone else that has all the different types of BMW programs that will diagnose the issue. Hopefully that will take care of it. Thanks again.

My 535xi had that whenever I pushed it hard enough and it eventually turned out to be a faulty Injector and so I replaced all 6. Never had that message come up ever again since... It's been 3 years and I never had it come up when My water pump failed either.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
My tech is saying that it might be an injector ... but he still taking it to the other BMW tech to be 100 sure but yes it might be the inejctor.. thanks again!
 
1 - 6 of 6 Posts
Top