BimmerFest BMW Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a 1997 bmw 540ia its black and has tan leather. Its a really nice car I love it!!! But I haven't drove it since mid april since it broke down. What happened is that when I was coming home from school the car would feel like it was stuck in 3rd gear and everytime i would try to give it gas it would just give me the transmission failsafe mode message. So I had to get it towed home. As soon as I got home I got my scanner to the car and the codes that I pulled up were p0720 which was something to do with the output speed sensor and another code something to do with that gear 3 had an incorrect ratio. But i bought the output speed sensor and I changed it out, put it back together and I still had no luck :( So I was looking up some info on the internet to see if anyone had this problem. And I found out that it may be the gear position switch underneath the car on the side of the transmission. What made me think that it was the problem with my car is that everytime that I would put it in gear it would show the gear I selected on the dashboard. But as soon as I give it gas it would just go into the failsafe mode and none of the gears will even show up and now I can't even get my car to start. So I took it off and took it apart and cleaned it up and put it back in, but my dumbass forgot to mark what the spot is was in so as of now my gears are all messed up!!!!! Dose anyone know how to get it back to normal?!?!!? But other than that I had the car on a lift and I finally found drive and nothing would happen. So i gave it some gas and the wheels were actually spinning. So i was glad that the transmission was still working. But what got me thinking that it was the drive train problem is that when the wheels were spinning. All the lights in the car and everything would flicker like there was a short or something. And it sounded like there was a grinding noise coming from the back of the car. Like 2 pieces of metal against each other. Maybe its a cv joint? :mad: As of right now i have no idea what it is. I don't want to take it in if i can fix it myself. If anyone could give me some advise on how i could fix it It would really help. Thank You!!!!!!!!
 

·
Registered
Joined
·
92 Posts
Start saving your pennies. You sir, need a new transmission. I had the exact symptoms. Throw the car in D and it wouldn't move. Rev it up a few times and finally the fail safe mode would activate. That locks the car in 3rd gear. You can change all the pulse generators (output speed sensors) you want, but they won't bring your tranny back. Ask me how I know. I was able to find a replacement tranny and have it installed all for $1,000. Good luck.
 
1 - 2 of 2 Posts
Top