BimmerFest BMW Forum banner

DSC light

2403 Views 12 Replies 6 Participants Last post by  Fast Bob
I recently bought this car and the warning light stays on (it's the orange circle with a triangle and exclamation point inside the circle located between the tac & speed).

Most of the time it stays illuminated but sometimes it goes off. It stays on more than off. I pressed and held the button to turn off (according to what I've read in the forums).

How can I fix this as I can't stand warning lights on.....

Thanks. :)
1 - 13 of 13 Posts
You could have a bad steering angle sensor
Thanks

I'll review that in depth. Thanks...
Just had the same issue and it was both of the pressure sensors
Thanks...

Thanks everyone.... When I bought the car they bought a different tire & put it on in order to sell the car. The tire place said they may not have plugged the sensor back in or damaged the wires.

Where is this sensor located & what should we be looking for? A wire with a plug/connector??

Thanks....
e46/2004/DSC ON/WATER ON RED !:(

i buy recently an e46 2004 and i have a very strange problem, when the engine is hot, and the water is at 1/2 ( normal position) if i turn the engine off , and i try to on the DSC is remaing on screen , the water is go to 180degree on red and he don`t let me turn on , i have in left panel the DDE light on , where is the problem?:( i don`t know what to do... today i stay 20min`s on gas station because i must wait engine cooled to turn on , if i stay 10-20 mins and the engine is cooled the car works , i put on a tester.. but no error :(

one guy tell`s me to change de ecu unit with ews and keys... i hope is not the problem

on walking the car not make problems any kind !s
You have a wheel speed sensor at all 4 wheels. Here is a pic of the front, rear is in a similar position. The wires chase back to a "black box", pop it open and unplug. If you find a BMW shop they should have the scanner you need to tell you which sensor is bad.

Thanks everyone.... When I bought the car they bought a different tire & put it on in order to sell the car. The tire place said they may not have plugged the sensor back in or damaged the wires.

Where is this sensor located & what should we be looking for? A wire with a plug/connector??

Thanks....
Thanks!

Thanks for such a great picture. I'm hoping whoever replaced the tire just forgot to plug/attach it back. :). Thanks for the great info as I read your posts all the time.
Yea, I have seen tire shops knock them around enough to cause this issue on more than one occasion. I would have to say that 50% of the time they can be "jostled" back to working. The other 50% they need to be replaced. And remember, they are magnetic sensors so cleaning them may be all that is needed. Just remove them (small allen key) and then give em a shot of brake cleaner and wipe them with a clean rag, done. In my case that did nothing and I had to replace it.

Hope that helps.
Thanks for such a great picture. I'm hoping whoever replaced the tire just forgot to plug/attach it back. :). Thanks for the great info as I read your posts all the time.
You`re hijacking someone else`s thread....BAD netiquette !!! :thumbdwn:

Start your own thread....
i buy recently an e46 2004 and i have a very strange problem, when the engine is hot, and the water is at 1/2 ( normal position) if i turn the engine off , and i try to on the DSC is remaing on screen , the water is go to 180degree on red and he don`t let me turn on , i have in left panel the DDE light on , where is the problem?:( i don`t know what to do... today i stay 20min`s on gas station because i must wait engine cooled to turn on , if i stay 10-20 mins and the engine is cooled the car works , i put on a tester.. but no error :(

one guy tell`s me to change de ecu unit with ews and keys... i hope is not the problem

on walking the car not make problems any kind !s
I'm sorry,i start my own thread but no answer:( i don't know what to do.. Today i stay at gas station 10min to cooled down engine,on tester has no errors:(
You`re hijacking someone else`s thread....BAD netiquette !!! :thumbdwn:

Start your own thread....
My fellow experts.....

Hi guys, this person sounds desperate.. It sounds like you need a new thermostat but the guys that have answered me probably know for sure. I'm a new BMW owner myself...
I posted an answer in your original thread.
I'm sorry,i start my own thread but no answer:( i don't know what to do.. Today i stay at gas station 10min to cooled down engine,on tester has no errors:(
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top