BimmerFest BMW Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2004 645 with 55K miles. I just got a Dynamic Control Error Message. I added fluid to the power steering and the error is still present. The icons appearing show a car on a slant as well as the ABS break icon.

The handling of the car is less responsive, breaking seems ok. Does anyone have any ideas on what is causing this and how to resolve it?

Thank you
 

·
Registered
Joined
·
347 Posts
You mean Dynamic Drive Malfunction? I've had this happen twice. First time was a year ago and it told me to pull over because of an issue with either steering or dynamic drive. Turns out the fluid level was low. Had it refilled and the problem never recurred - until this morning! I was driving on a highway and the red warning you describe popped up. Didn't tell me to stop the car, just warned of more body roll than normal (and body roll was very noticeable - like in my old toyota!)

I pulled the car over, turned it off and removed the key, and then restarted and the issue did not recur.

2006 BMW 650i Vert
 

·
Tirona
Joined
·
604 Posts
You mean Dynamic Drive Malfunction? I've had this happen twice. First time was a year ago and it told me to pull over because of an issue with either steering or dynamic drive. Turns out the fluid level was low. Had it refilled and the problem never recurred - until this morning! I was driving on a highway and the red warning you describe popped up. Didn't tell me to stop the car, just warned of more body roll than normal (and body roll was very noticeable - like in my old toyota!)

I pulled the car over, turned it off and removed the key, and then restarted and the issue did not recur.

2006 BMW 650i Vert
Sometimes its a problem w the sensor. I had my car displaying the error all the time till i figure out that it was the sensor.
 

·
Registered
Joined
·
1,169 Posts
Thanks for the help, where is the sensor at? Did you replace it MG650?
Sensor(s), lots of them all over the car. Only a dealer can fix as iDrive needs to be programmed/reset.

Except for brakes and some basic service, all electrical repairs have to be done at the dealer. Period.
 

·
Registered
Joined
·
347 Posts
I didn't replace anything as the problem has not recurred since the one time earlier this week. Seems like it was a momentary glitch.
 

·
Registered
Joined
·
347 Posts
Happened again - this time accompanied by warnings indicating failure of the traction control system as well as the start-assist system (its a 6 spd - prevents car from rolling backward on starts)

Just went out to restart it and all warnings are gone. I have a lot of leaf debris under the car (roads where i live are covered with leaves now and collecting in wheel well etc) - wonder if that can interefere with sensors?
 

·
Tirona
Joined
·
604 Posts
Happened again - this time accompanied by warnings indicating failure of the traction control system as well as the start-assist system (its a 6 spd - prevents car from rolling backward on starts)

Just went out to restart it and all warnings are gone. I have a lot of leaf debris under the car (roads where i live are covered with leaves now and collecting in wheel well etc) - wonder if that can interefere with sensors?
No u got to check it out. It seems like u got a problem. Something might be wrong. So better check it out.
 

·
Registered
Joined
·
347 Posts
Dealer has it now and is replacing the module that controls dynamic drive. Thx guys for the advice.
 

·
Registered
Joined
·
347 Posts
They confirmed it was the dynamic drive control module that failed. Dealer replaced it under warranty so I have no idea what it cost. Took them 2 days just to get the part but were able to complete the job in a day once it came. I am morbidly curious as to what it would have cost so I'll ask. (had the module that controls the roof/windows replaced 3 weeks ago and they told me it would have been about 900 to 1000.)
 

·
Registered
Joined
·
30 Posts
can somebody tell me were the power steering fluid resovoir is located? Is it rite next to the anti freeze overflow tank? Thanks

Danny
2005 645 conv
 
1 - 14 of 14 Posts
Top