BimmerFest BMW Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1 (Edited)
Hi all,
I drive a 2004 BMW 745LI with 85000KM (Kilometers not Miles).
Happened to me a about a week ago I got error message "Dynamic Drive Inactive"...something like on Curves...contact your BMW center..turned off the car turned it back on everything was fine...Today was on my way home when I got same message again and after turning the car off & then on again error message was gone but as I was driving its like lights inside the dash and Navigation screen went off it was like blackout all lights went off & came back on within few seconds but with error message "Dynamic Drive Inactive" but after I pulled over & turned off the car turned it back on everything was fine but this happened twice during my ride home today the blackout situtation while driving after second time I made it home safe while i was backing up in my garage samething happened after the blackout but also got a message saying "Transmission failsafe" along with "Dynamic drive inactive" turned the car off waited few mins and when i started the car again everything was good I even drove the car out of garage and backed up again but nothing this time....Any idea as to what could be the problem???? Just so you all know I know I am low on my break fluid and the brake service is due also and I am getting the Brake oil change this saturday...I gona ask the mechanic to check why I got the messages but wana get your opnion ....so what could be wrong with the car? Any idea please...?Thanks in advance for all your feedback....
Regards
 

·
Registered
Joined
·
768 Posts
try and do hard reset.. disconnect your battery for some time. that would be easiest way to fix, most of the time bad battery throws up tons of errors but you were rolling when that happened so. check your fuses just in case, easiest way also before going to mechanic...once my car was acting weird too such as wipers wouldnt work and same error message. it was raining and i hit gas and car went spinning 180 so i was facing cars that were behind me on a busy road. then few days later eveerything worked normal again ever since.
 

·
Wilassasin
Joined
·
2,614 Posts
You need either a battery or alternator, just got mines done same issue a few months back...I needed an alternator...BTW the dealer couldnt figure it out i had to help them out a bit thanks to bimmerfest!!
 

·
Registered
Joined
·
768 Posts
first thing i thought of was battery but he was driving when that happened so to pick between these two it's alternator
 

·
Master Tinkerer
Joined
·
2,218 Posts
Get your brake fluid up and check your power steering fluid as well, but the blacking out of things sounds more like a voltage issue (alternator/battery). Ack...posted right after everyone. Anyway, agree with rustar.
 
 

·
Registered
Joined
·
313 Posts
No fault to the original poster... but man - this has got to be like the 8th battery/alternator thread I have read in the past two weeks... Maybe we need a sticky titled "dynamic drive inactive, parking brake fault - why?" :rofl:
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
Thanx everybody for your input...going in this saturday to have brake oil changed & now gona ask them to check for the error messages too, hope its not gonna be something serious or a big problem/issue....
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
Ok so here is the situtation, I had the car checked today, computer scan and Ive been told that its the CAS the ignition cas (switch, where key goes). Battery is good and after I asked the mechanic the alternator is fine too, so ive been told to replace the CAS, just wana get inut before i book the next appointment and have it replaced....Any ideas?
Also mechanic told me i need to have the software updated in the car and that only once the software update is done he will find out if there are any computers (like mini computers) that I might have to replace because the ones in the car are not capable of getting the updates of new software and this could end up being costly in tersm of $$$ but again he told me I should get CAS replaced ASAP thats the major fault and then after that I should be good......any idea as to what he said, what is he talking about...sorry guys I am not good with this stuff so just want your input/feedback...thanks again....
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
yeah thats what I was getting from the fellow members on this forum but I know that mechanic did like a test on battery and showed me like a slip confirming batter is OK (Good) thats when I asked him about alternator and he said yes alternator looks fine...so from what I am geting from mechanic is that battery and alternator are both fine.....
 

·
Registered
Joined
·
66 Posts
i had battery issues and power issues as well. Dealer told me the same the same thing...the CAS ignition module was acting up...they replaced...was a little over a grand...but that fixed it. no issues since...
 

·
Registered
Joined
·
1 Posts
2004 745Li

Did you find out the actual solution for this problem? I'm having the same issue with my 2004 7 series. Please let me know if you found out the problem. Thanks!
 

·
Registered
Joined
·
570 Posts
Did you find out the actual solution for this problem? I'm having the same issue with my 2004 7 series. Please let me know if you found out the problem. Thanks!
No, the OP is one of those guys that comes to the forums, gets all the info & help from members, then figures out his problem & doesn't give a s h i t to participate & post the solution!:thumbdwn:
 

·
Registered
Joined
·
5 Posts
Hey guys,

I was having a similar issue on a 745 Li, I would get the following error: "Dynamic Drive Inactive", this would happen right after the instrument pannel/mmi would turn off/back on. This would happen mainly during turns, or at high speeds on the freway. I took the car to this guy in LA and he checked everything on it, turns out it was a loose battery cable - positive. I think I got lucky on this one but I thought I'd mention it. Sometimes it may pay off to check all the connections before taking the car to a random mechanic or worse, the dealer. The guy I took the car to spent quite a bit of time on it and still charged a minimum ammount - honest guy, so that was cool. Anyway, good luck.
 

·
2playok
Joined
·
2 Posts
I just has this happen on the way into work today. Also saw the below in one of those pay sites as a response from a tech. The item missed which could also be a cause would be the belts that may make it seem like a battery/alternator issue.

The dynamic drive inactive message by itself is not specific. It is only intended to let the driver know there is a problem. The most common causes of this warning are a low fluid level/leak, problem with the sway bar, or failing alternator/voltage problem. The only way to verify is to have the fault logs read from the car using a diagnostic computer. However, given that the dash is also going off and on, this very much points to a voltage problem - alternators are very very common to fail on this car. At this point I would advise you to check connections at the battery and alternator, but most likely the alternator is the problem. This can be verified by having the alternator tested, or the fault logs read from the vehicle.

Just a follow up, It's now a few weeks later. As most see, you turn the vehicle off and the error code resets itself. However a different one popped up a few days later and went away. I have a feeling it is battery related, but I have not had any more warning lights since. Winter is here and I'm just buying some additional time. I suppose I should actually see how old my battery is.
 

·
Registered
Joined
·
67 Posts
Hi guys, I know this thread started a long time ago but this happend to me also today as I was driving on the highway at around 100km/h. Just want to let you know that I have a low power battery as I get a fault on the dash about the battery if I let the electronics on with the engine turned off... I live in Quebec and today was a cold day (so cold that my idrive button wasnt working and my CD changer was making a strange noise when I put the key in ignition) so I let the car at idle before driving it for about 10 min to let it warm up a bit i always do this on winter days... Less than 2 min after getting on the highway the Dynamic drive fault came up and while it was showing up on the dash, the radio cut off for 2 seconds than came on normaly. Cleared the error from dash and idrive screen and it automaticly show up again... Also noticed that the car was leaning really bad on sides when taking curves and turns.... Drived like that until reached destination. Two hours later as I had to go back home, I let the car with the engine running for almost half an hour before driving to be sure the engine and everything is warmed enough. Surprise! The dynamic drive fault didnt showed up again and the car was running normaly when taking turns and curves... but I'm afraid the fault will come again on the following days.

Do you guys think in my case is just the battery or because it was really cold outside? Or maybe because it was so cold that the battery lost power? Didnt had any problem to start the engine but as I said I get a battery low power fault if the electronics are on with the engine off. Also, is it bad to drive the car with a low battery?

The car is a 2006 750Li.

ImageUploadedByBimmerApp1417571175.369058.jpg
 

·
2playok
Joined
·
2 Posts
You could easily take it in and get the battery and charging system tested. And yes, you need to drive a bit more carefully when the Dynamic Drive system is inactive.
 

·
Registered
Joined
·
67 Posts
If I change the battery do I need to take it to the dealer or It can be done by any shop? I heard that when changing the battery it has to be set up with the computer... Is it true?
 

·
Registered
Joined
·
2,454 Posts
Yes it needs to be registered. Any shop with the right software can do it.
 
1 - 20 of 35 Posts
Top