BimmerFest BMW Forum banner
1 - 8 of 8 Posts

·
Spitfire
Joined
·
609 Posts
Discussion Starter · #1 ·
Hello everyone, it's been a really long while since I posted something here.
Anyways, 2004 U.S. spec M3. Got it on the dyno, and nothing !

1st gear, the wheels begin to move. At around 3,000 RPM the car just drops back to idle.
Turned DSC off, same thing. Took the DSC fuse out, same thing.
The DSC light just comes on and the car idles again.

What to do ??
 

·
Black Mage
Joined
·
2,337 Posts
Do the M3's have the 3-step DSC like non-M's? If so, you might wanna try holding the button down for a few seconds until the "BRAKE" light comes up green.
 

·
Spitfire
Joined
·
609 Posts
Discussion Starter · #4 ·
I'm afraid weve tried that, but to no avail !

Any other suggustions please ??
 

·
M Mad
Joined
·
10,476 Posts
Do a search. M3 is not easy to dyno, especially later ones. You may need 4 wheel dyno and fans to simulate airflow (some people believe the system will not allow full RPM unless can know it is moving).
 

·
Spitfire
Joined
·
609 Posts
Discussion Starter · #6 ·
So, a simulator dyno could do the trick.
Thanks for the advice man ! I'll see what I can do.
 

·
HMFIC
Joined
·
439 Posts
I'd post over on M3forum.net. Or search there. That forum gets a ton more traffic.
 

·
Spitfire
Joined
·
609 Posts
Discussion Starter · #8 ·
Was there just now, thanks anyways everyone !

Looks like the GT1 will do the trick or else an EVOSPORT dyno would also but it's not available here .

Thanks again !
 
1 - 8 of 8 Posts
Top