BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
hi folks

before i go on, i can add that i finally cured my rough idle..... :bigpimp:

after shopping for ireland on un necessary parts (idle air valve, fuel pump, lambda sensor, and maybe more) i found that the black valve on the head manifold was bust. also some air tank was also gone but the bmw mech bypassed it, said its not needed.

now i got a rock solid idle. the fuel pump relay was also bust...:p

so, now my dials/clocks are screwed. they keep going on and off whilst driving, everything goes, and then comes back on.

the only think that stays unchanged is the milage, (of course) sometimes the trip counter resets as well.

whats wrong? is it a relay or something? i dont fancy buying a new dash.....
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
clocks

well the milage is unchanged, the trip sometimes resets, and all the handsgo dead, and lighs go out, then back on again (most times)

wheres this sensor, i need more details sham!

eric
 

·
Registered
Joined
·
346 Posts
Before trying the sensors, make sure your speedo cluster works probably. Sometimes, those little motor/servo things inside went busted.

To test it, do the following....
1. Engine off, Key off (position 0)
2. Press and hold the milage reset button
3. While doing that, turn Key to Position 1 (=ACC)
4. Release the button
5. Sit back and enjoy the show~~

If the needle works fine (they sweep their whole range of motion), then try tackling the sensors, wirings, etc...

There should only be 1 sensor connected to the diff if my memory serves me right. Jack stand the car up and have a look.
 
1 - 5 of 5 Posts
Top