BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
1994 325is with only 130,000 miles. Fails California smog test at idle for HC emissions. HC at high rpm is just fine.

Oil was changed ~500 miles ago and have run a bottle of Cataclean through the tank. Only use premium gas. Took her in hot and it failed....
Car drives well. MPG is around 30 hwy and her giddy up is still strong. No issues with exhaust smells and engine sounds like everything is firing ok.

Check engine light has never come on. Everyone says it must be the cat (as they scratch their head) but there aren't enough miles on the car to convince me. And that's an expensive fix... Plugs are at least 3 years old (meaning 15,000 miles ago).

Any advice? Please please please.....


1039199
 

·
Registered
Joined
·
3,817 Posts
What spark plugs are in it? The M50 does not like the fancy iridium 4 prong spark plugs. It works best with high quality (hard to find now) single prong copper spark plugs.
 

·
Registered
Joined
·
73 Posts
Move to Texas. Just kidding (not really). I used to live in California, and I found a plug change the day before could make a big difference in the “sniffer” test. It used to be that if your car failed, if you brought it in for a second test after a repair and there was an improvement, your car would be approved even if the numbers were still too high. A plug change and a second test would probably get you approved if this is still the law.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top