BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Sorry in advance if this problem has been answered already. I did a quick search and found some similar problems, but they don't seem to be the same as mine.

1998 740iL 190k miles, recently purchased.

Was driving fine until a few weeks ago.

Problem 1: When I start the car in the morning, or after sitting for a few hours, the car is very very slow to accelerate. The gears DO shift. In Neutral, the engine revs just fine. After 30-45 min of driving, it will eventually warm up back to normal. The temperature gauge is at normal.

NOTE: The TRANSMISSION FAILSAFE light occasionally comes on, but not everytime. Also, if it makes any difference, the "CHECK REVERSE LIGHTS" and "CHECK BRAKE LIGHT" come on every now and then, even though the lights are working fine. Another light that comes on occasionally is "CHECK COOLANT LEVEL" even though that seems to be fine as well.


Problem 2: Only noticeable on highway (~65mph+) when on the gas, the car will clunk/pull every couple hundred yards, sometimes with a 'whining' noise right before each clunk.

I'm not sure if these two problems are related, although I wouldn't be surprised.

I've changed the engine oil of the car, as well as the transmission fluid, with no results. Note: Transmission fluid was very very dirty with signs of what looked like metal flakes inside. As I said, the car drove fine a few weeks ago, and these problems have slowly been getting worse since they started.

I've been to a few mechanics, but they admit they're not too experienced with these cars. Any help is greatly appreciated.

Thanks in advance!!

EDIT: Forgot to mention that filter was also replaced*************
 

·
Old School
Joined
·
4,123 Posts
Metal and burnt transmission fluid not good. Fuel filter also a good (read cheap) place to start. With slow pick-up (slipping transmission) and metal flakes you need a GOOD indy transmission shop. The globe fail OBC 'sees' old and smoked out globes as defective. Just change them and clean up the globe holders. System self resets.
 

·
Registered
Joined
·
14 Posts
If you're in San Francisco, it might be worth finding a good Audi/BMW/Mini/Porsche shop to go to that isn't a dealer. They could probably figure it out and cut you a decent labor rate if you become a regular, and working on cars isnt your thing.
 

·
Registered
Joined
·
1 Posts
Is your problem solved?

I am having the exact same issue with my car, same model and year too. I was wondering what ended up being the probelm and how did you solve it.
 
1 - 4 of 4 Posts
Top