BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Alrighty guy I'm back with good and bad news. The good the 540i starts an runs the bad is that it's not running properly. I replaced the icv(I have about 5valves laying around) ccv, put new fuel 93octane of course, new spark plugs, and new ignition coils,

The reoccuring codes are
p0300 random misfire detected
P0303 misfire cyl 3
P0505 idle air control system
P1585 from what I'm told is misfire detected low fuel
had codes or the back two o2 sensors I cleared them and they haven't returned as of yet...
Once I got codes for all Of the o2 sensor
Po150,p0135,p0141,161

Continued: I checked cyl 3 to see if it is igniting. Sadly it isn't... Still looks like a new plug, I event unplugged the coil to check if the idle changes and nothing. The idle changed for the other 7cyls and swapped out coils and plugs with neighboring cyls so switched cyl3 into 2 and cyl 2 to 3

So my question is what should I do next.? I also have new injectors so I may install those just for the hell of it
I just want to get this car inspected and driven like the ultimate driving machine that it is.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #2 ·
Also having the problem with the cooling system air keeps building up after I have bled the system, but the car just keeps overheating. Help with most of these problems. Never had the cooling problem with this thing.
 

·
Under the lift arms
Joined
·
13,166 Posts
Lot of variables there dude, with your hand in the cookie jar like that...

you could start by conferming that coil pack 3 is being told to fire.
take it off put any spark plug you have laying around the garage in it.. and place it plug down to a ground... turn the car over... have somoene do that for you while you look to see if its fireing

the o2 codes are probably cause of the mis fire
you might have a ECU problem
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #4 ·
If it's not being told not to fire what are the possible variables to look into. I'm eliminating a bad dme because it's a brand new dme that I had reprogrammed and was working with two other engines before spun bearings and a crankwalk. From my calculations of guess and check its a 6%percent chance its a bad dme. But other than that. I could have fault wiring in the main engine harness I havent checked that yet.
So my question what to check after checking for spark in cyl 3 coil pack
 
1 - 4 of 4 Posts
Top