BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi,

Yesterday my 525d started vibrating in 3rd gear at between 2500-3500rpm ish. It's only really noticeable at 50% throttle or more. I've tested it several times and it is consistent.
In all of the other gears, there are no signs of vibrations no matter how I drive. The flex-plate / guibo and center-mount were changed about a month ago. Should it be necessary to tighten these after I have driven for a while? Could that be my problem?
Info about the car;
E61 LCI 525d
Engine Stage 2
Transmission XHP Stage 3

All answers are appreciated and feel free to ask questions if any important information is missing :)
 

·
Registered
2006 530xi 6 MT
Joined
·
4,710 Posts
The flex-plate / guibo and center-mount were changed about a month ago.
Given these were recently changed, this is the mostly likely problem. They do not call for re-torquing after some number of miles. It may be overreacting, but you just don't know what exactly is wrong. If you can't inspect it yourself, I may not even drive the car.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Given these were recently changed, this is the mostly likely problem. They do not call for re-torquing after some number of miles. It may be overreacting, but you just don't know what exactly is wrong. If you can't inspect it yourself, I may not even drive the car.
Going to lift it up after work today and have a look. But what do you mean by "overreacting"?
 

·
Registered
2006 530xi 6 MT
Joined
·
4,710 Posts
Going to lift it up after work today and have a look. But what do you mean by "overreacting"?
When I wrote "overreacting", I was referring to my own thoughts about being concerned enough to not drive the car until the problem was found.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
When I wrote "overreacting", I was referring to my own thoughts about being concerned enough to not drive the car until the problem was found.
The car is on the lift now and i went over ever bolt and all were tight and i can not find and slack anywhere on the drivetrain....
 
1 - 5 of 5 Posts
Top