BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
So I am about to go crazy with a friend's 2006 750li. It is stuck in P and won't go in N, D, or R. I work a lot on classic cars in my shop, so I am not very used to all the electronics in the newer cars but I am doing my best to learn. That being said, I am just trying to help my buddy out here to save him some $, but I'm at a point where I'm giving up. So I really need your help here guys. Please!

I have been browsing through this forum for the past two weeks and afterwards it was clear to me that changing the Transmission Mechatronic Sleeves should fix the problem. So I got this repair kit from Amazon https://www.amazon.com/gp/product/B01NCTIYUJ/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1 and followed all the instructions found on here carefully. The bridge seal adapter was in bad shape so I was sure that is the issue. I did not change the 4 round ones in the middle because they looked fine to me. Unfortunately still the same problem, it won't go into any gear. So I took it apart again and measured the resistance of the solenoids, and even though it all appeared to be fine, I ordered the original parts from ZF and also replaced all of those including wire harness. Unfortunately this did not solve the problem either. There was also no metal debris in the transmission pan so I think the actual transmission is fine. I also followed instructions on how to fill in the oil.

I am seeing the following error messages in the display:

  • Parking Brake Malfunction: I looked into that and the gears in actuator are broken.
  • Brake and Drive Control System malfunction
  • DSC Malfunction
  • Flat Tire Monitor Unavailable
  • Passenger Belt Fastener Malfunction
  • Washer Fluid Low

Then I setup INPA to be able to read and clear all codes. I attached the error codes here. I am receiving:

Transmisison:
  • 507C
  • 51AD

All control module
  • EGS 51AD
  • DSC 5F20
  • EMF D3BD
  • EMF 6044
  • SSBF 97E0
  • DME/DDE 29DD
  • CAS A0B5
  • KLIMA 9C64
  • KLIMA 9C7A

I did research on it but I am not sure what all of that means, so I am hoping on your expertise here. Any ideas what the problem is? I am out of ideas... Thank you!!!_a_
 

Attachments

·
Registered
Joined
·
79 Posts
This happened to me.

I asked and asked but nobody could tell me anything . My 2006 750li was stuck in park. This is how you fix first buy all the modual that are inside the tranny. Dont rely on the codes just buy them all they come in a kit its aprox 450.00. then buy all the gasket that yo0u should replace when you drop that pan. take your time replacing all the moduals and make sure you buy the correct tranny fluid. put it back together and it will be fixed and just like new. Total cost will aprox 575.00. The dealer wanted ?10,000 to fix.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
I asked and asked but nobody could tell me anything . My 2006 750li was stuck in park. This is how you fix first buy all the modual that are inside the tranny. Dont rely on the codes just buy them all they come in a kit its aprox 450.00. then buy all the gasket that yo0u should replace when you drop that pan. take your time replacing all the moduals and make sure you buy the correct tranny fluid. put it back together and it will be fixed and just like new. Total cost will aprox 575.00. The dealer wanted ?10,000 to fix.

@Roadrider: I have replaced all of what you mentioned already. I actually started another post because this one took over a week to be released by the admins. Here is the link: https://www.bimmerfest.com/forums/showthread.php?t=1321793
 
1 - 3 of 3 Posts
Top