BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
I have a 2000 328coupe and recently have noticed a few weired electrical problems.
just the other day while my other half was driving the car she stalled it, restarted the engine and started to drive away but the ASC light stayed on in the instument cluster, even when the button was pressed frantically many times, but once the ignition was turned off then back on, normal operation proceeded. then on another occasion again while driving normally with the lights on, the drivers side (uk car so right hand) headlight went out, showing this on the idiot lights on the dash, but the front right indicator came on staying lit perminantly? also the remote central locking works intermitently?
Any ideas or technical info on the electrical system would be great. thanks.
 

·
Registered
Joined
·
148 Posts
i believe the indicator light always comes on when the headlight goes dead.....if the bulb has already been changed and the indicator stil stays on then i guess you'll be needing much more expert advice from forum users
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #3 ·
it's strange, only happened when lights are set to side lights, once you move ith through to dipped beam then it sorts itself out. have an incling that it's something to do with the battery, as that's been letting me down recently, a new one on its way tommorow.
 

·
Registered
Joined
·
148 Posts
id say you need to check your headlights to see if any of them are dead first......if they are then i think that would be the reason for the head light.......if they are not then you an go ahead with the other symptoms....

this is because ive seen MY lights do this....on the 03 compact that i owned and my 330....it was the fact that the headlight was or parking light was out both times
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #6 ·
got the car this afternoon, checked the lights, and at first glance it looked as if the bulb had blown, it had the warning light on the dash to show, and as you said the indicator was on permanantly, i turned the ignition off and put the lights in the sidelight position, and the otherside done the same so had both indicators on and both light warnings illuminated. i changed the battery for the new one i got today restarted the car put the lights back on and they both worked!?! tried turning them off, then on and worked fine, also checked all other electrics (windows, aircon, sterio, seats etc) as well as other lights all fine. will keep an eye on it but will put it down to those gremlins that everyone talks about. thanks for info anyway, cheers.
 
1 - 6 of 6 Posts
Top