Bimmerfest BMW banner

1 - 7 of 7 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
Hello all.
I haven’t had to ask for help in a while (lucky)
My 03 530 said failsafe. It still runs and drives fine. But the hazards come on and won’t go off also on my dash the turning signals and brights don’t work. Also my radio controls. From what I’ve read first is to check the volts.
My question is I got 15.5ish when running.
Is that to much?
It should be 14 or so???
Tested the battery and it was 13.2
Should I change my alternator ?
Has anyone had this problem?
Thx for any help


Sent from my iPhone using Bimmerfest mobile app
 

·
Registered
2001 BMW E39 540i Automatic Sedan, 192 K miles
Joined
·
1,576 Posts
Yes,

13.2 v on the battery is very good, if a bit high.
15.5 v on the alternator is definitely high, close to the danger zone of 16 I think.

First, try to drive to your nearest Autozone parts store and have them check and load test your battery and alternator. It is free.
 

·
Wingnut
Joined
·
3,703 Posts
a good charged battery will always read higher than normal immediately after charging or having run the car for a time due to the surface charge the higher charge voltage applied to it. if youre unsure of it, turn the headlights on for 5 minutes without the engine running then re read it. a healthy battery will read 12.65 vdc. as stated above, any decent parts store will be able to tell you the health of the charging system in 5 minutes at no charge.
what code(s) is it giving you?
 

·
Registered
Joined
·
178 Posts
Discussion Starter #4
I’m not getting any codes for that at least. Just a couple lean codes


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
178 Posts
Discussion Starter #5
One other thing I found. I hooked up my PA soft. program. The LCM wasn’t found. I’m guessing that’s why all my light problems.


Sent from my iPhone using Bimmerfest
 

·
Registered
2001 BMW E39 540i Automatic Sedan, 192 K miles
Joined
·
1,576 Posts
Then you definitely have an electric / charging problem. Check your alternator.
 

·
Wingnut
Joined
·
3,703 Posts
what kinda scanner did you use for your original code read? after trying PASOFT, did you get any new code(s)? if the failsafe was triggered, even if if cleared itself, there should be a saved code there.
 
1 - 7 of 7 Posts
Top