BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Gave up on trying to find the answer for this one on the site.
So sorry guys...

My 528ia has an issue with the engine somtimes going out. It mostly happens at low revs, but sometimes the engine temporarly goes out at higher speeds. I short bumb is felt when this happens.

Reading the error code from the car I learned that the camshaft sensor needed replacement, which was done. The engine started to seemingly be running smoother, but problem persisted:cry:. Now I get an error reading concerning the idle system. My mechanic wants to change the nocksensor...Not sure if that is the right path.

Any input on this is much appreciated...:)
 

Attachments

·
Registered
Joined
·
2,998 Posts
When that happened on my Dodge truck I was stumped. Replacing the crank sensor seemed to make it run better, but the engine would still stop when ever it felt like it. I noticed that when it quit it didn't have any fuel pressure so I replaced the fuel pump. Seemed to run better but the engine still quit when ever it felt like it. Took a really experienced Dodge mech to tell me what was wrong, replace the ecu he said, and it will fix your problem. I was skeptical but replaced the ecu, he was right, all was good again.

Don't know if its the same with your car, just something to think about. Also, the ecu wasn't able to diagnose it's own failure. In hind sight I feel pretty stupid not being able to figure that out.

Jim
 
1 - 6 of 6 Posts
Top