BimmerFest BMW Forum banner

1 - 20 of 32 Posts

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #1 ·
1030975

1030976

After replacing my alternator cause it was shot , (I also replaced my belt) my car is giving me the engine malfunction low power and these codes . Any thoughts? I’m at a loss
 

·
Registered
Joined
·
888 Posts
Are these all new codes, or is it possible that they all occurred when your car was suffering from low voltage due to the bad alternator? At any rate, it would be helpful to throw a voltmeter on your battery buss and see what kind of voltage you DO have (verifying that the new alternator is working, which isn't always the case, either due to a bad new alternator, or wiring / control problem).
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #3 ·
Are these all new codes, or is it possible that they all occurred when your car was suffering from low voltage due to the bad alternator? At any rate, it would be helpful to throw a voltmeter on your battery buss and see what kind of voltage you DO have (verifying that the new alternator is working, which isn't always the case, either due to a bad new alternator, or wiring / control problem).
I think I left the ground on my alternator a little loose gonna check that and the alternator is working checked with volt meter
 

·
Registered
2006 530xi 6 MT
Joined
·
4,715 Posts
I also think some of these things that are complaining are on the BSD (bit serial data) bus. IBS, water pump, alternator. Perhaps that wire is damaged.
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #5 ·
I also think some of these things that are complaining are on the BSD (bit serial data) bus. IBS, water pump, alternator. Perhaps that wire is damaged.
Where would I locate that wire ?
 

·
Registered
2006 530xi 6 MT
Joined
·
4,715 Posts
The alternator has the big ass positive wire. But, there is also a small connector that plugs into it -- that is the BSD connection on the alternator.
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #8 ·
The alternator has the big ass positive wire. But, there is also a small connector that plugs into it -- that is the BSD connection on the alternator.
I’m gonna check both of those connectors when I get off work here
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #9 ·
Ok so the only code I have now that’s engine related is the 30ff so I’m gonna go through the process of checking all my vacuum lines and pipes . Gonna replace all the vacuum line anyways and move my way towards the boost solenoids and waste gate actuators if none of that works I’ll suspect the turbos at that point . Anyone still here ? :)
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #10 ·
I’ll prob have to drive her just to and from work under 10 miles for the week or two it takes me to fix her should she be okay as long as I don’t drive her hard enough to engage limp mode ?
 

·
Premium Member
2001 325i sedan 5mt, 2009 535xi Touring 6mt
Joined
·
504 Posts
If you're getting it under heavy throttle around 2,500 RPM I'd think it's wastegates. But definitely worth searching for boost leaks elsewhere. Vacuum lines to boost solenoids is also worth investigating, and the solenoids themselves.
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #12 ·
If you're getting it under heavy throttle around 2,500 RPM I'd think it's wastegates. But definitely worth searching for boost leaks elsewhere. Vacuum lines to boost solenoids is also worth investigating, and the solenoids themselves.
Can a catalytic converter code have any correlation with my issue it just popped a cel
 

·
Premium Member
2001 325i sedan 5mt, 2009 535xi Touring 6mt
Joined
·
504 Posts
Can a catalytic converter code have any correlation with my issue it just popped a cel
I would generally think a catalytic converter code would mostly have to do with emissions and not much else, but I could certainly be wrong. I've never encountered problems with cats before so I haven't spent time diagnosing them.
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #14 ·
I would generally think a catalytic converter code would mostly have to do with emissions and not much else, but I could certainly be wrong. I've never encountered problems with cats before so I haven't spent time diagnosing them.
I appreciate you man you rock .
 

·
Registered
Joined
·
888 Posts
The one exception to the cats affecting only the rear O2 sensor's readings is when one is clogged to the point that it creates a lot of back-pressure. If this is the case, the car may run more or less correctly until you start pushing it - the more throttle, the more back-pressure, and the less the turbo(s) will do their magnificent job(s). But you have to give us the actual code (and even then, it's a bit of a guess that's based on symptoms, too).
 

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #16 ·
The one exception to the cats affecting only the rear O2 sensor's readings is when one is clogged to the point that it creates a lot of back-pressure. If this is the case, the car may run more or less correctly until you start pushing it - the more throttle, the more back-pressure, and the less the turbo(s) will do their magnificent job(s). But you have to give us the actual code (and even then, it's a bit of a guess that's based on symptoms, too).
What do you mean the actual code?
Its 30ff : " Charging pressure control , charging pressure too low "
 

·
Registered
Joined
·
888 Posts
Sorry - wasn't sure if it was the same code in the last iteration, and your post made it sound like it was a catalytic converter-related code.
 

·
Registered
Joined
·
396 Posts
30ff means the turbos were deactivated. There is no single reason why as far as I can tell. I'm about to replace the two turbo solenoids on our 535xi to see if it helps. I think the computer can turn off the turbos whenever something gets too far out of spec too.
 
  • Like
Reactions: Kingbmp

·
Registered
2008 BMW 535i N54
Joined
·
42 Posts
Discussion Starter · #20 ·
30ff means the turbos were deactivated. There is no single reason why as far as I can tell. I'm about to replace the two turbo solenoids on our 535xi to see if it helps. I think the computer can turn off the turbos whenever something gets too far out of spec too.
Is that also why I’m getting the engine malfunction and feeling limp ? Just no turbos ?
 
1 - 20 of 32 Posts
Top