BimmerFest BMW Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Has anyone gotten this warning message on their 335? I took my car to the dealership and they only temporarily fixed the problem. It came back the next day; I take it back and again they only temporarily fixed it. Maybe I am going to wrong dealership: Concord, CA. Would appreciate any insight.
 

·
Registered
Joined
·
4,072 Posts
sounds like the HPFP, but ouch, Concord is my dealer too. :eek:
 

·
Registered
Joined
·
376 Posts
It could be the HPFP, but in my case, it was the fuel injectors....that seems to be happening as well.
 

·
Registered
Joined
·
28 Posts
HPFP vs. Injectors

See my recent post - http://www.bimmerfest.com/forums/showthread.php?t=410259

I am getting a new HPFP on my 2009 335i tomorrow. My adviser said if it was the fuel injector, the wait time would have been between 1-2 weeks because the parts are "in high demand" across different states.

I am curious if anyone else heard similar statements?

Andrew
 

·
Registered
Joined
·
4 Posts
Had the same problem. happened to me two weeks after picking the car up!!!! Service tech told me that it is a common problem with the 3 series, and that i needed the High Pressure Pump. Once replaced, a difference was felt as the newer pumps that they put in are the updated part.
 

·
Registered
Joined
·
98 Posts
The only time it happened to me I had to replace one of my turbos. The defect description was: Exhaust turbocharger (ATL) incorrect or no switching action. It's much more likely to be the HPFP though. Hopefully that's the case because I had to go without my 335 for a week while the turbo was replaced.
Good Luck...
 

·
Enjoying Your Money
Joined
·
572 Posts
Has anyone gotten this warning message on their 335? I took my car to the dealership and they only temporarily fixed the problem. It came back the next day; I take it back and again they only temporarily fixed it. Maybe I am going to wrong dealership: Concord, CA. Would appreciate any insight.
SF BMW, ask for Jorma Nottbohm, he is the best and super honest CA I have ever dealt with :thumbup:
 

·
Registered
Joined
·
1,694 Posts
Could be 100s of things. Get a BT cable and review the codes yourself, so you can tell the dealer what to replace when you take it in. Good insurance against them wasting your valuable time with BS diagnosis designed to stall major repairs.
 

·
Skjoni's Dad
Joined
·
1,733 Posts
Had the same problem. happened to me two weeks after picking the car up!!!! Service tech told me that it is a common problem with the 3 series, and that i needed the High Pressure Pump. Once replaced, a difference was felt as the newer pumps that they put in are the updated part.
My first new hpfp was a different part number than the oem pump, so I was hoping it was an improved version. Then it crapped out 3000 miles later and was replaced again with the same "new" part number pump. So my oem pump lasted 11,000 miles, and my "new" pump lasted 3000 miles. :rofl: Nothing has been fixed yet, sorry to say.
 

·
Skjoni's Dad
Joined
·
1,733 Posts
Last week picked-up new 335i x At 60 miles got check engine light. Dealer said they had to "switch the vanos right to left and left to right" ? ! Any one heard of this?
Depends if you're right or left-handed.
 

·
Registered
Joined
·
9 Posts
Same on mine

My 335 has done the exact same thing. Same message. It started a few weeks ago when the start button had a bit of trouble firing the engine up. Then the other day it died after a rough start and had no power. It is being towed tomorrow to Stevens Creek BMW since the service guy said do NOT drive it. Im curious to see what they say and praying it wont be a constant issue for the future.
 

·
Registered
Joined
·
6,805 Posts
Last week picked-up new 335i x At 60 miles got check engine light. Dealer said they had to "switch the vanos right to left and left to right" ? ! Any one heard of this?
Do not walk, but RUN from that dealer.... If your car is at the dealer, you may need to invest in some hip waders to get through the bullsh*t they are pushing.
 

·
Registered
Joined
·
6,805 Posts
My 335 has done the exact same thing. Same message. It started a few weeks ago when the start button had a bit of trouble firing the engine up. Then the other day it died after a rough start and had no power. It is being towed tomorrow to Stevens Creek BMW since the service guy said do NOT drive it. Im curious to see what they say and praying it wont be a constant issue for the future.
Magic 8 Ball says your car has fuel system issues.
 

·
Registered
Joined
·
6,805 Posts
three is a charm, lemon maybe... if it cant be fixed
In California, it is 4 failed repair attempts with a written letter to BMW NA requesting assistance before the 4th failed repair attempt. If you don't meet the notice or the 4 failed repair attempts requirement, you don't get to go to court on BMW's dime. However, if the notice requirement and 4 failed repair attempts requirement is met, then California Lemon Law is no bullsh*t and BMW is paying for your legal representation from the moment you qualify for the Lemon Law remedy.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top