BimmerFest BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
i have a rattle in my engine (2004 645ci) when i start it up from cold it is vastly reduced when the engine warms up and a good Bmw indy near me reckons it is the hydraulic lifters at fault and that he has seen it a few times , has anyone ever done this on there 6er or do you reckon it could be the cause ???
 

·
Registered
Joined
·
113 Posts
My 2005 645ci has the similar sound, in the winter and in the morning when the engine is cold it does seem to be noisy, after 5 minutes when it warms up it is normal. I read on these forums that if you get your injectors cleaned and use a good fuel additive/cleaner it will help reduce this noise. I did it today so I don't have any results for you, give me until the end of the week and I will post up results. CHEERS:thumbup:
 

·
Registered
Joined
·
196 Posts
Discussion Starter · #3 ·
standard fuel here is 99 octane and has cleaning additives already in them , but i did pop in a can of BG44k a few months back didnt really make any difference:(

is there any known issues with the lifters / tappets in these or with the vanos unit ???
 

·
Registered
Joined
·
555 Posts
i have a rattle in my engine (2004 645ci) when i start it up from cold it is vastly reduced when the engine warms up and a good Bmw indy near me reckons it is the hydraulic lifters at fault and that he has seen it a few times , has anyone ever done this on there 6er or do you reckon it could be the cause ???
You and everyone else with a N62, don't worry about it; unfortunately, it's the norm.

Sent from my iPhone using BimmerApp
 

·
Registered
Joined
·
277 Posts
I too have an engine rattle/tick noise coming from under the hood when I first start her up on cold mornings. I suspect it is the same issue with the lifters. I haven't gotten any quotes yet but I plan on having this addressed in the near future. If you have this service done can you please post the cost for this service. I've noticed cost for 6er repairs vary widely depending where you go. I would just like to know what a fair price/estimate would be.
 

·
Registered
Joined
·
1 Posts
Hi guys ! I have a 630i -2008 55k miles automatic gearshift . And this morning i left in a hurry ... I always leave engine running ar least 5 minutes but this morning i just got in the car and left. It was -1 but over night it was quite a similar temperature. After 10 mins driving i got the engine management yellow light in the dashboard and car start to shake and make funny noise probably that "rattle " that ppl mentiond here . I stopped the car and switch engine off , leave it for 5 seconds then started the car again. Yellow light was gone then i ve hammered the car a bit with a few kick downs and drive it for more . Nothing came on back. I m going later to a good independent beemer service to check it out . I hope it s nothing serious and deffo i will always leave engine running . Also I've noticed now in the winter when I start the engine it makes for a few minutes a thin squeeqin noise probably form a bearing that holds a belt or something ... Couldn t trace it but it s gone after a few minutes. Pls let me know if the yellow light was a sinple problem of letting car to warm up or something else . I will keep you updated as well. Thank you guys ! G
 
1 - 6 of 6 Posts
Top