BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 · (Edited)
on my 01 Mroadster after coolant was drained and refilled. Autozone scanner did not work it kept getting "Link Error". Maybe coolant got onto the OS??? Any suggestions??? TIA
 

·
Registered
Joined
·
288 Posts
Wish I could help, but I have a similar problem with my 2000 M coupe. I had a CEL telling me my 02 sensor 1 - 3 pre-cat was bad. Changed all sensors now I have a CEL telling me 1 - 3 post cat is bad :dunno: When I reset the light doesn't go out, however when I start the car and drive the light is off...until I turn off the car and restart it again :mad:
 

·
Im here
Joined
·
4,825 Posts
Hey Ron, not to jack this thread but i got my peak tool today, there site shows a r5/srs-16 for 2001-2003 that is what i ordered, I got a r5/srs per reciept says 93-00 models?
is this the right one do you think, i do have the round connector under the hood and tool is round
 

·
19,585 Miles
Joined
·
11,141 Posts
01silber said:
Hey Ron, not to jack this thread but i got my peak tool today, there site shows a r5/srs-16 for 2001-2003 that is what i ordered, I got a r5/srs per reciept says 93-00 models?
is this the right one do you think, i do have the round connector under the hood and tool is round
I have the same one. It works on my car (used it last night since I had the drivers air bag out) but comes up with the flashing E (communication error) when you do a reset. I worked with Dan Peake on this but he never followed through.
 

·
Registered
Joined
·
288 Posts
Ron Stygar said:
Did you replace with BMW sensors?
Well, I have Bosch in the front, since Bosch was out of stock, and Siemens in the back (from Pelican) which were the same as the ones I took out.
My airbag light is also on. I tried to reset and got the "E" also, and Dan from Peake sent me a website to go to for add'l instructions, but that didn't help either.

http://www.peakeresearch.com/srstech.htm

Lights are still shining! However, the car drives just fine.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #7 ·
Here's the update.
I came by a BMW repair shop this morning and the mechanic there cleared the error after opened and closed the gas cap. I don't know how did that happen I haven't touched it for a week.

So, which Error Reader should I get?
 
1 - 7 of 7 Posts
Top