BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1 (Edited)
So, I still have this problem with my 2011 328i xDrive. Here is what it does.. When Im driving down the road everything seems fine, however once I pull up to the stop sign or a traffic light and I make a stop and with car still in D and brake applied I notice a random engine shake. When idle, RPM gauge jumps up and down from 600 to 750rpm. Its so bad that most of the time I put it in Neutral just to stop my car from wobbling left and right. First thing I can think about is the Ignition, however there are no faulty codes. :dunno: I have taken it to BMW Service few times only to be told that they could not recreate the problem. So Im hoping that someone can shed some light on this issue.
Im looking into buying a brand new set of Ignition Coils and Spark plugs. I have found the whole set on ebay for about $190 but im unsure if Ignition coils are the problem and also if this set of ignition coils and sparks plugs is any good since its so cheap. http://www.ebay.com/itm/BMW-E82-E90...tem1c60bc6823:g:UIEAAOSwL7VWr1ZN&vxp=mtr#rwid

Also, I have looked into performance ones. Does the extra cost really make a difference?
Thank you very much.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #4
Well, there are no vacuum leaks. I searched google and came across this https://www.youtube.com/watch?v=mUqqrR06PoM Im experiencing the same problems. I disconnected Mass Air Flow Sensor and drove it around the block. Car seemed fine. Im going to clean out Mass Air Flow Sensor good and see if that fixes it.
 

·
Registered
Joined
·
2,187 Posts
Ahhh...us Turbo folks do not have that but I did experience that on my wife's car when I disconnected vent tubing to throttle and car went nuts. Threw MAF errors but once reconnected it was fine.
 
1 - 5 of 5 Posts
Top