BimmerFest BMW Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I need your help regarding a check engine light problem that the dealer and BMW Germany can't fix on my 2008 535xi. If I let the car sit for at least 12 hours and then start it up, the engine starts skipping, the car shakes violently, and the check engine light turns on. This happens for about 5-10 minutes until the engine warms up. Can someone who has a 2008 535 try this and let me know if they have the same problem.

I am bringing the car in today. This is the 3rd time for the same problem. What course of action can I take against BMW?
 

·
Registered
Joined
·
2,940 Posts
I've had a 535i loaner for a few days, and that doesn't happen on it.

Might want to check the lemon laws.
 

·
Retired Official Welcomer
Joined
·
8,310 Posts
Can we say:

 

·
Registered
Joined
·
1,186 Posts
Find a different dealer. My educated guess is that a fuel injector(s) is leaking down after shutoff causing a flooded condition in one or more cylinders. Any smoke associated with the rough running on start up?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #5 ·
Find a different dealer. My educated guess is that a fuel injector(s) is leaking down after shutoff causing a flooded condition in one or more cylinders. Any smoke associated with the rough running on start up?
I would agree if it ran rough for a few seconds. The engine continuously shakes for about 5-10 minutes. The check engine code says misfires in all 6 cylinders. There is no smoke associated with this problem, just loss of power.
 

·
Registered
Joined
·
199 Posts
I have an 08 535xi that's 6 days old... nothing similar to report after sitting overnight
 

·
Registered
Joined
·
3,109 Posts
I have an 08 535xi that's 6 days old... nothing similar to report after sitting overnight
Everytime my 08 535i has been sitting in the garage for a couple of days, it'll be rough for 15-30 seconds then goes to normal. Not shaking violently for minutes.
From past experience, I had this on all my cars after car wash (only driven in-out and back) into the garage; so I guess it's normal.

What kinda of gas did you use? and what octane?
So I-drive tells you you have misfire on all 6 cylinders?, I'll bring it in right away.
So many things can go wrong, Coil packs, ignition module, fuel pump etc. The coil packs is unlikely since you have misfire on all 6 cylinders.
Keep us posted, and good luck.
 

·
Registered
Joined
·
5,372 Posts
Sounds like injector leak down to me.
 

·
Registered
Joined
·
1,186 Posts
Wet plugs could cause a misfire but would likely clear up before ten minutes.
Anything that manifests itself this long, is repeatable and as pronounced as you say should be easily diagnosed by BM.
Comebacks presumably go to the the original mechanic, perhaps you should request a different "tech". Unless a design flaw EVERYTHING can be fixed.
Your frustation is understandable but to state BMW can't fix it is wrong.
Contact your zone representative, fill him in and ask for a recommendation.
Good luck
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #10 ·
Everytime my 08 535i has been sitting in the garage for a couple of days, it'll be rough for 15-30 seconds then goes to normal. Not shaking violently for minutes.
From past experience, I had this on all my cars after car wash (only driven in-out and back) into the garage; so I guess it's normal.

What kinda of gas did you use? and what octane?
So I-drive tells you you have misfire on all 6 cylinders?, I'll bring it in right away.
So many things can go wrong, Coil packs, ignition module, fuel pump etc. The coil packs is unlikely since you have misfire on all 6 cylinders.
Keep us posted, and good luck.
Shell 93 Octane as recommended by BMW.
No, the dealership read the check engine code.

Visits to the dealership and result:
1st) It's a high level of ethanol in your gas, use Shell premium.
2nd) It's the high pressure fuel pump; installed new pump.
3rd) We will see...
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #11 ·
Wet plugs could cause a misfire but would likely clear up before ten minutes.
Anything that manifests itself this long, is repeatable and as pronounced as you say should be easily diagnosed by BM.
Comebacks presumably go to the the original mechanic, perhaps you should request a different "tech". Unless a design flaw EVERYTHING can be fixed.
Your frustation is understandable but to state BMW can't fix it is wrong.
Contact your zone representative, fill him in and ask for a recommendation.
Good luck
The dealership has contacted BMW directly about this problem with no solution so far.
 

·
BMW NA Customer Relations
Joined
·
454 Posts
I need your help regarding a check engine light problem that the dealer and BMW Germany can't fix on my 2008 535xi. If I let the car sit for at least 12 hours and then start it up, the engine starts skipping, the car shakes violently, and the check engine light turns on. This happens for about 5-10 minutes until the engine warms up. Can someone who has a 2008 535 try this and let me know if they have the same problem.

I am bringing the car in today. This is the 3rd time for the same problem. What course of action can I take against BMW?
I'm with BMW of North America, LLC. I've passed this message on to a BMW NA Customer Relations Representative who will be in touch with you soon.
 

·
Registered
Joined
·
218 Posts
I have a 535 with 7k miles on it...never had an issue like yours or anything even close...and it has sat for two or three days on occasion.
 

·
Registered
Joined
·
2,741 Posts
I had the similar violent shaking occasionally with my old car about a year after i graduated college (93 grand cherokee). Last April, after 187k miles i was on the highway one day and realized i had to floor it to keep up with traffic. And then...everything became quiet. I lost power steering and was pretty lucky to be able to move from the middle to the left lane to the left shoulder while slowing down insanely fast. Anyways the problem turned out to be the fuel injector so that'd be the first thing I check/replace.

Once that vehicle died I made the best decision ever and went with an 04' 530i.
 

·
Registered
Joined
·
36 Posts
Sounds to me like you have either a fuel injector leaking, as others have stated, or you're somehow getting condensation built up that is affecting the plugs, wire, coil, ignition, something...the engine's running may result in things getting dried out and then the car runs fine. You need either a new technician or a new dealership. Sorry to hear of your problem - sounds frustrating...
 

·
Registered
Joined
·
21 Posts
Same

I need your help regarding a check engine light problem that the dealer and BMW Germany can't fix on my 2008 535xi. If I let the car sit for at least 12 hours and then start it up, the engine starts skipping, the car shakes violently, and the check engine light turns on. This happens for about 5-10 minutes until the engine warms up. Can someone who has a 2008 535 try this and let me know if they have the same problem.

I am bringing the car in today. This is the 3rd time for the same problem. What course of action can I take against BMW?
MINE DOES THIS TOO!!! Mines a 08 535i and sometimes when I get into it and hit the button to start it skips for about 3-5 seconds and starts up. When it does start up the cars completely fine. I don't have the car shaking violently and check engine light problem though....Any suggestions?
 
1 - 18 of 18 Posts
Top