BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Hello guys,

Recently finished several retrofits, but are stuck on some fault codes, that appear in ISTA, so looking for advise from someone that are really "deep" in coding.

Faults I would like to get rid of are related to NBT, M-sport steering wheel and rain-sensor retrofit.

So I have F20 with zeitkriterium 11/13. Car I would say was equiped with litteraly nothing from factory.

So regarding NBT.
1) Had HU_ENTRY without COMBOX before retrofitting NBT. Using emulator. Problems is with GPS antenna, GSM antenna and fault regarding incorrect unit fitted. GPS and GSM antennas are connected directly to NBT, but car looks for the COMBOX and I guess therefore faults regarding antennas disconnection appear. Once again - there was no COMBOX from factory, neither it is installed now. Everything is VO coded and double checked with FDL, that GPS_FROM_NAVI is active and so on. Still can not get the BT and GPS to work. Do someone know how do I get rid of COMBOX ecu being detected as missing ECU (picture attached)? Maybe if I get rid of it, antennas will be detected... Should I play with zeitkiterium?

2) How to get rid of the fault regarding wrong audio unit installed?

NBT was not flashed with the car yet.

Regarding M-sport steering wheel
1) After fitting the wheel, cruise control not working anymore, while trying to activate (picture attached). Before retrofit had multifunction steering wheel - everything was working properly. After retrofit added 710 option and coded needed ecus - FEM, ICM, BKOMBI and NBT. In my opinion problem is in BKOMBI, as when I try to scroll through FM station list now, they will not apear on KOMBI, as before retrofit. But I can change the stations with right side buttons. BTW all buttons seems to be working, excluding LIM (limiter). Any gyess here?

Regarding rain-sensor
1) From the start will say that everything works as it should - headlights turn on automatically, wippers works and so on.
Fitted another light switch with auto position, fitted another SZL with auto wippers function... Why do I get this error?

Hope there is an expert here that can help on those problems, as I am totally stuck... :dunno:
 

Attachments

·
Registered
Joined
·
308 Posts
When you installed nbt, you must change and kombi to 6wa with most connection. For combox you need write new FA to vcm, and delete combox.
No need any emulator to make it work everything

I can help you with remote coding

Also have for sale virgin 6wa cluster with deleted vin and mileage


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
Thanks for your reply.

Changed FA is already written to VCM. Regarding changing BKOMBI to 6wa - I do not believe it is a must... Have seen others done NBT retrofit without upgrading combi. So probably you mismatch something here. Right now car has no MOST bus at all, as there were no COMBOX before.

Basically I just need GPS and BT (GSM) antennas to work... And believe problem is that car looks for COMBOX and "tries" to get antennas signal from there, as antennas are connected directly to NBT.
 
1 - 3 of 3 Posts
Top