BimmerFest BMW Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
Brought my car in today to have the above checked. On deceleration in any mode i can hear a gurgling/popping sound coming from the exhaust. Seems to happen in any drive type I'm in: sport or comfort. Now the gurgling sounds kinda cool but the popping sounds like a back fire to me but hey what do i know? So they changed all the plugs and when i picked up the car, same sounds, no difference at all. So i met with the foreman of the service center and says he compared the car to another 650 and they both make the same noise. And that he can't find anything wrong with the car. I've read on other posts here that this is meant to be? I understand the whole throaty aggressive sound of an exhaust thing and i like that but to me this doesn't sound right. Anyone else have experience with this? Btw, i have the M-sport package if that matters.

Thanks everyone!
 

·
Registered
Joined
·
136 Posts
Discussion Starter #3
Sounds like the "flapper" valves at the exit of the mufflers are wired open or are broken in the open position (unlikely). Mine sure doesn't do this.
Thanks for the reply. Is yours an M sport? I'm asking because i've read that the M sport is tuned differently and purposely to make that gurgling burping sound.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #9
Ok gotcha. (I think) so let me see if I have this right: you swapped out mufflers to get the gurgling, burping and backfire sounds?

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
404 Posts
Yea, I' m a bit of a car freak and just enjoy the sounds. As a kid, it was lake pipes made your blood rich....takes less renosence now!
 

·
Registered
Joined
·
61 Posts
I own a 2013 650 vert and wondered the same thing. When it was at the dealer for service the technician said the sound was completely normal the flaps or injectors closing...happens when I applied the brakes.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #13
It turned out to be normal confirmed by a BMW engineer at the service center.


Sent from my iPhone using Tapatalk
 
1 - 13 of 13 Posts
Top