BimmerFest BMW Forum banner

1 - 12 of 12 Posts

·
Super Moderator
Joined
·
7,068 Posts
What do you mean by "load the fem_body?" Are you getting the error when you "Read Coding Data" or "Code" or "Code FDL?"
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Thanks for the reply.

It's when trying to read the fem body to get into it.

All the rest I can read and program fine...
 

·
Premium Member
Joined
·
40,354 Posts
Hi All,

I have been recently receiving this error but only when trying to load the fem_body.

Everything else works fine - did a clean and new install and same thing. Any clues?

Thanks in advance

http://tinypic.com/r/rrvcq9/9

Your Picture shows a Mapping Error, which means you have either chosen incorrect E-Sys Launcher Car Series or E-Sys Connection Target.

And what car are you connecting to? You show in profile to have F07, but F07 does not have an FEM_BODY module.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
Hmm everything works but the fem... strange.

I have an f30. 2012 328.

Not sure what I am doing wrong then. Have programmed the car plenty in the past. I guess I'll have another look through?!
 

·
Premium Member
Joined
·
40,354 Posts
Hmm everything works but the fem... strange.

I have an f30. 2012 328.

Not sure what I am doing wrong then. Have programmed the car plenty in the past. I guess I'll have another look through?!
Ok, the picture does not lie though. It shows a mapping error, and since many chassis do not have an FEM_BODY body module, it is due to selecting one of them incorrectly. Make sure Launcher is not set for F99.
 

·
Registered
Joined
·
5 Posts
Dear Shawn, Dear Experts,

I tryed to code the memory function for the start stop automatic (TC_MSA_Memory) a few days earlier. I used the following equipment (ESYS 3.27.1, Launcher Premium 2.5.3, psdzdata 59.1). Everything works fine until the latest popup, after FDL coding. Here I got an error message and the memory funktion is not activated. I worked exactly after the relevant instructions, also I watched some videos before coding. Car was connected to a ctek-charger and the battery was fully loaded. During the coding I also noticed nothing unusual, e. g. voltage interruption. At best I was a little bit to slow. ;-) Today I tryed it again and got the following error, now already after reading coding data of FEM_BODY:

Transaktions-Report: Aktion: Codierdaten lesen
FEM_BODY [40] [ÿÿÿÿÿÿÿ]
readCPS o.k.
CAFD_FFFFFFFF_255_255_255 Fehler:
Datei für "cafd_ffffffff-255_255_255" wurde nicht gefunden! [C012]


I have already read something about this error, but I'm wondering what is wrong. During coding I'm not asked about the PIN I allocated during installation of tokenmaster software. Is this normal, or is the software corrupted and maybe this is the reason for the fault?
So what can I do now to fix the actual problem and then for coding the memory-function?

Best regards, Bernie.
 

·
Registered
Joined
·
158 Posts
Hi Bernie,

cafd_ffffffff-255_255_255 means that you've corrupted your FEM_BODY CAFD file while coding.

You can try to "DETECT CAF FOR SWE" and select the CAFD with the I-level matching the I-LEVEL CURRENT on your car, and the code the FEM_BODY module again.

But since you've mentioned you did not need to enter a PIN, first try to reinstall E-SYS and E-SYS Launcher Premium just in case E-SYS is the problem.

Does everything still works in your car?
 

·
Registered
Joined
·
5 Posts
Thank you. I reinstalled the programm already and also not asked after a PIN? Strange. Actually I noticed no faults in car, thank god! I can post/send also the log from coding day if this can be helpful. I have also the CAF-File (backup) from folder DATA\CAF.

Here is a part of LOG-File, many data, but maybe a hint to the fault (VIN deleted by myself):

Timestamp: Tue Jul 05 20:53:27 CEST 2016
ErrorCategory: SYSTEM_ERROR ID: 2130759743
Class: com.bmw.psdz.vehicle.connection.util.ResultUtil
ExecutionContext={category=TAL, ecuid=(FEM_BODY,0x40), TA_CATEGORY=cdDeploy, PROGRAMMING_STATUS=finalizeECUCoding,PSdZEvent={message=MCDDiagService<id=230900, job=com.bmw.psdz.jobs.uds.MCD3_FinalizeECUCoding, service=DSC - DiagnosticSessionControl, description=error: timeout, link=Physical request to ECU with address 0x40>, timestamp=Tue Jul 05 20:53:27 CEST 2016, package name=com.bmw.prodias.execution.primitives.mcd, class name=SingleEcuJob, text id=MCD_EVENT_ID__JOB__SERVICE__DESCRIPTION__LINK__, event id=default, event type=DiagService error, null},PSdZEvent={message=MCDDiagService<id=230900, job=com.bmw.psdz.jobs.uds.MCD3_FinalizeECUCoding, service=DSC - DiagnosticSessionControl, description=error: timeout, link=Physical request to ECU with address 0x40>, timestamp=Tue Jul 05 20:53:27 CEST 2016, package name=com.bmw.prodias.execution.primitives.mcd, class name=SingleEcuJob, text id=MCD_EVENT_ID__JOB__SERVICE__DESCRIPTION__LINK__, event id=default, event type=DiagService error, null},PSdZEvent={message=MCDDiagService<id=230900, job=com.bmw.psdz.jobs.uds.MCD3_FinalizeECUCoding, service=DSC - DiagnosticSessionControl, description=error: timeout, link=Physical request to ECU with address 0x40>, timestamp=Tue Jul 05 20:53:27 CEST 2016, package name=com.bmw.prodias.execution.primitives.mcd, class name=SingleEcuJob, text id=MCD_EVENT_ID__JOB__SERVICE__DESCRIPTION__LINK__, event id=default, event type=DiagService error, null},PSdZEvent={message=MCDDiagService<id=36900, job=com.bmw.psdz.jobs.uds.MCD3_FinalizeECUCoding, service=RDBI_ADS - ReadDataByIdentifier ActiveDiagnosticSession, description=error: timeout, link=Physical request to ECU with address 0x40>, timestamp=Tue Jul 05 20:53:27 CEST 2016, package name=com.bmw.prodias.execution.primitives.mcd, class name=SingleEcuJob, text id=MCD_EVENT_ID__JOB__SERVICE__DESCRIPTION__LINK__, event id=default, event type=DiagService error, null}}MCD Error Code: 0xd03fMCD Error Code Description: Module offlineVendor Code: 0x4e47Vendor Code Description: link is no longer active
at com.bmw.psdz.vehicle.connection.util.ResultUtil.checkResponsePositive(ResultUtil.java:77)
at com.bmw.psdz.vehicle.connection.util.ResultUtil.getPositiveResponseOrTerminateOnError(ResultUtil.java:177)
at com.bmw.psdz.vehicle.connection.wrapper.LegacyJobWrapper.terminateOnError(LegacyJobWrapper.java:649)
at com.bmw.psdz.programmer.facade.ProgrammerImpl.finalizeECUCoding(ProgrammerImpl.java:901)
at com.bmw.psdz.talexecutor.tasks.CodingTask$Finalization.doExecute(CodingTask.java:197)
at com.bmw.psdz.tasks.base.TaskStep.execute(TaskStep.java:119)
at com.bmw.psdz.tasks.base.SingleEcuTask.executeFinalization(SingleEcuTask.java:841)
at com.bmw.psdz.tasks.base.SingleEcuTask.execute(SingleEcuTask.java:506)
at com.bmw.psdz.tasks.base.scheduler.RunnableTask.run(RunnableTask.java:212)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)
16-07-05 20:53:27,687 [TRACE] [] com.bmw.psdz.system.configuration.languagemapper.LanguageMapperImpl: Custom language mapping to language 'deu' was not successful, using 'eng' as default instead. [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
16-07-05 20:53:27,687 [TRACE] [CodingTask - vin:xxx- ecu:FEM_BODY - da:0x40] com.bmw.psdz.vehicle.connection.wrapper.LinkPool: closeECUConnection started [ParallelTask-6]
16-07-05 20:53:27,687 [TRACE] [] com.bmw.psdz.system.configuration.languagemapper.LanguageMapperImpl: Error: Language Mapper could neither map error id '2130759743' to intended language 'deu' nor default language 'eng'. Returning empty string instead. [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
16-07-05 20:53:27,687 [DEBUG] [CodingTask - vin:xxx- ecu:FEM_BODY - da:0x40] com.bmw.psdz.vehicle.connection.wrapper.LinkPool: detaching from logical link FEM_BODY_40_ETHERNET use count = 0 [ParallelTask-6]
16-07-05 20:53:27,687 [TRACE] [] com.bmw.psdz.system.configuration.languagemapper.LanguageMapperImpl: Custom language mapping to language 'deu' was not successful, using 'eng' as default instead. [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
16-07-05 20:53:27,687 [DEEP_TRACE] [CodingTask - vin:xxx - ecu:FEM_BODY - da:0x40] com.bmw.psdz.vehicle.connection.wrapper.ConfiguredDProject: execute stopCom on logicalLink FEM_BODY_40_ETHERNET [ParallelTask-6]
16-07-05 20:53:27,687 [TRACE] [] com.bmw.psdz.system.configuration.languagemapper.LanguageMapperImpl: Error: Language Mapper could neither map error id '2130759743' to intended language 'deu' nor default language 'eng'. Returning empty string instead. [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
16-07-05 20:53:27,687 [DEBUG] [CodingTask - vin:xxx - ecu:FEM_BODY - da:0x40] com.bmw.psdz.vehicle.connection.wrapper.ConfiguredDProject: trying to remove logical link FEM_BODY_40_ETHERNET from project [ParallelTask-6]
16-07-05 20:53:27,687 [TRACE] [] com.bmw.psdz.system.configuration.languagemapper.LanguageMapperImpl: Custom language mapping to language 'eng' was not successful, using 'eng' as default instead. [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
16-07-05 20:53:27,687 [INFO] [CodingTask - vin:xxx - ecu:FEM_BODY - da:0x40] com.bmw.prodias.execution.DefaultJobProcessor: logical link FEM_BODY_40_ETHERNET is not cleanly removable, but will remove (and reset) it anyway [ParallelTask-6]
16-07-05 20:53:27,687 [TRACE] [] com.bmw.psdz.system.configuration.languagemapper.LanguageMapperImpl: Error: Language Mapper could neither map error id '2130759743' to intended language 'eng' nor default language 'eng'. Returning empty string instead. [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
16-07-05 20:53:27,687 [DEBUG] [CodingTask - vin:xxx - ecu:FEM_BODY - da:0x40] com.bmw.psdz.vehicle.connection.wrapper.ConfiguredDProject: successfully removed logical link [ParallelTask-6]
16-07-05 20:53:27,687 [WARN] [] com.bmw.esys.commons.exception.EsysExceptionHandler: PSdZ Error -- Exception in executeAsync. [C046] --- [Ljava.lang.String;@1410b3a [com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread]
com.bmw.esys.domain.psdz.PsdzException: Exception in executeAsync. [C046]
at com.bmw.esys.domain.psdz.PsdzEventExceptionListener.onException(PsdzEventExceptionListener.java:170)
at com.bmw.esys.domain.psdz.PsdzEventExceptionListener.eventReceived(PsdzEventExceptionListener.java:83)
at com.bmw.psdz.uc.event.RegisteredEventListener.eventReceived(RegisteredEventListener.java:59)
at com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread.notifyListeners(ExternalSynchronizedHandler.java:140)
at com.bmw.psdz.uc.event.ExternalSynchronizedHandler$AsynchronousNotificationThread.run(ExternalSynchronizedHandler.java:126)
Caused by: negative response error:
code: the result contains an error
description: Service DSC has error in result: [Severity=2051][ErrorCode=53311][ErrorCodeDescription=Module offline][VendorCode=20039][VendorCodeDescription=link is no longer active]; ECU: FEM_BODY_40_ETHERNET
severity: ERROR
 

·
Registered
Joined
·
29 Posts
Discussion Starter #11 (Edited)
Hi Shawn,

I've checked all settings and they seem good.

Launcher is set to f30.

Loading the f020 when connecting to the vehicle.... Any other thoughts I may be able to try?

Not sure what I'm missing here, like I've said I have programmed this many times before. Just been awhile and wanted to go back into it and now this error?

Thanks
 

·
Premium Member
Joined
·
40,354 Posts
Hi Shawn,

I've checked all settings and they seem good.

Launcher is set to f30.

Loading the f020 when connecting to the vehicle.... Any other thoughts I may be able to try?

Not sure what I'm missing here, like I've said I have programmed this many times before. Just been awhile and wanted to go back into it and now this error?

Thanks
Send me TeamViewer Login, and I'll look at it.
 
1 - 12 of 12 Posts
Top