Bimmerfest BMW banner

61 - 80 of 82 Posts

·
Registered
Joined
·
7,059 Posts
My coder and I are scouring the web for more info... He believes it may be a Firmware specific to the TPMS module. Not necessarily the year. I believe it is possible too because there are "--" in front of the Pressure and Temp which tells me, numerical values should be there.
That is correct. TPMS is a bit different in later model year cars from what I understand also.
 

·
Registered
Joined
·
5,766 Posts
Has anyone been able to confirm/deny if they can code the high-beam function to the "adaptive high beams" (or whatever the term is they use for that specific tech)?
 

·
Registered
Joined
·
7,059 Posts
Has anyone been able to confirm/deny if they can code the high-beam function to the "adaptive high beams" (or whatever the term is they use for that specific tech)?
Yes, I did mine. Some work fine. Some cars with a bit later software work only if the lights come on after the car is already driving, then the high beam assist is default on. That is how mine is (High beam assist not auto on if lights trigger on immediately when car is started, but if they come on after car is already running high beam assist is on). Oddly, even older software didn't have this issue, then was updated and this issue cropped up. Then software updated again and now high beam assist works ok again. Hope that makes sense.
 

·
Registered
Joined
·
5,766 Posts
Yes, I did mine. Some work fine. Some cars with a bit later software work only if the lights come on after the car is already driving, then the high beam assist is default on. That is how mine is (High beam assist not auto on if lights trigger on immediately when car is started, but if they come on after car is already running high beam assist is on). Oddly, even older software didn't have this issue, then was updated and this issue cropped up. Then software updated again and now high beam assist works ok again. Hope that makes sense.
You can now have it where the high beams stay on with approaching traffic, but outline the oncoming traffic to avoid glaring them, or yours just turn on and off automatically?

My post was referring to the high beams staying on constantly (like some of the videos on this forum have shown), and not just the "auto" feature that clicks them on and completely off when traffic approaches. V/r, Tim


Sent from BimmerApp mobile app
 

·
whughes
Joined
·
2,026 Posts
so, I ordered the cable, that gets you hooked up with your laptop, what software do you use to actually do the programming? instructions?
 

·
Registered
Joined
·
3,903 Posts
Big shout out and thanks to octopump (Richard)!

Wonderful guy of great character with whom you can talk on many levels; autos, tech, society, politics, business; just a solid, solid guy.

He coded my car last night at the Autostrade Auto Show in Glen Cove, NY and didn***8217;t move on to his next client until he was sure I was completely happy with all of the results! Gave me his full and undivided attention.

Highly recommended. The best.
 

·
Registered
Joined
·
539 Posts
Discussion Starter #70
OMG.
BMW updated the software on all modules and all my coding is gone. I am just realizing how cool these features were!
I am now bumping into the door because a single pull opened it. Feel like a dummy ;)

Re-coding a going to a real pain. The SSD on my Macbook Air booked it and along with that my Windows VM with the installed software on it. Now everything again from scratch :(
 

·
Registered
Joined
·
743 Posts
Has anyone here tried coding with the BMWhat app?

If it does what you want, might be easier than getting your VM loaded and running again.

***** I looked at it on the iPhone App Store, does not look like it supports coding for the F01 yet *****
 

·
1st Time Bimmer (F02)...
Joined
·
346 Posts
Update: octopump coded my car; great job thank you!! Anyone in NYC/Long Island looking to have it done, he's comes well recommended.



Sent from BimmerApp mobile app
he will be coding my car probably this weekend. just waiting for my cable to arrive, which should be this friday.
 

·
Registered
Joined
·
338 Posts
he will be coding my car probably this weekend. just waiting for my cable to arrive, which should be this friday.
How did the coding go, Valdez? You mind sending me details on the latest software download and where you purchased your cable?
 

·
1st Time Bimmer (F02)...
Joined
·
346 Posts
Yes, my apologies as i had intended to create a thread about my coding experience with the good Mr. octopump (Rich). It was difficult to catch up at 1st due to some technical difficulties on my end and our conflicting, busy schedules, but we were eventually able to make it happen. I must say that even thru all of that it was pleasure to deal with Rich. He was always very communicative throughout the process, explaining everything in detail and taking the time to answer any questions i had.

I would definitely recommend his services to any and all after dealing with him. For the price, the extra little features that you are able to "unlock", it is definitely worth it. Thanks again, Rich!
 

·
Registered
Joined
·
223 Posts
Well finally got my car coded by Octopump today. It was a very smooth and interesting process. I am looking forward to the new experience these unlocked features will give in my driving experience. He was professional and prompt thanks Rich
 
61 - 80 of 82 Posts
Top