BimmerFest BMW Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Hi again guys

I am trying to figure how much mpg(liter per kilometer)my car consumes(523 m52 single vanos)

I think my fuel level sensor is not working fine,

it says I have 15 liters in my car and then on next day its says i am on reserve(light comes on)

then I started experiment just driving car until its dies my dashboard says 0 kilometers but i have already driven about 15 kilometers, I dont know what the hell is this

can someone help me?
 

·
Registered
Joined
·
2,998 Posts
I have had the same problem. What I found is: The mileage left, is a reflection of your driving at that time, updated bout every minute. When you start it in the morning, the act of starting it uses more fuel than the driving you were doing last night, as does driving it slowly out of your neighborhood warming it up. Also had upon occasion, the last 20 miles to empty or so, drop really, really fast on the, "miles left" reading. Not fun when you are quite a ways out of town with no gas station in sight.

Solution: Don't let the car get real low on fuel, it will be lower in the morning than it seemed when you finished driving it last night. I've taken to not letting my car get much below 1/4. An added benefit, your less likely to suck up crud from the bottom of the tank, like it does when you let it get real low on gas.

Jim
 

·
Registered
Joined
·
2,846 Posts
two things.. run chevron techron fuel system cleaner in you car...
and when you start your car on low fuel it reads low.. as you get going about 20min it will give you a better reading..in some cases you will start off with the low fuel light and then when the car gets enough data will increase the mileage and even turn off the light..
 

·
Registered
Joined
·
182 Posts
Discussion Starter #4
well i am from 5 km from my work cold start doing its own of course,

while i will use system cleaner I am gonna replace o rings for injectors, already changed o2 sensors,

also I have removed catalystconverterand car has much more power i think xD

thanks for your help.
 

·
Registered
Joined
·
2,846 Posts
be real careful with the o-rings.. many here have reported damaging the injector just by removing them...
 

·
Registered
Joined
·
2,846 Posts
i would suggest using your o2 to see if you have an air leak and NOT replace the orings if you don't have an air leak..
 

·
Registered
Joined
·
182 Posts
Discussion Starter #8
I have gas smell at cold starts, my friend told me its because of removed catalyst,

others say its o rings...

what the hell should i do?
 

·
Registered
Joined
·
2,846 Posts
monitor rpm to STFT and run engine from 1k to 2k to 3k and then 2k then 1k rpm over a 90 second time frame.. 12321 for 90.. watch the stft... if it decrease say from 10 down to 2 then you have an air leak.. if it matches you rpm you might have a fuel issue... if it drops to neg you may have a maf issue or leaking injectors..
 

·
Registered
Joined
·
2,846 Posts
"what the hell should i do?"

you should stop guessing and do more testing.. with your cats removed what did you do with your downstream o2?
 

·
Registered
Joined
·
182 Posts
Discussion Starter #12
when i removed my o2 sensors they were very bad, they had sounds while i trampled them in my hands and they were burned with black smoke, I installed another ones
 

·
Registered
Joined
·
2,846 Posts
If you removed you cats then the back o2 will have a sinus pattern like the pre cat o2 and will toss an CEL and using a scanner you will get the p-code for that.. it's important that your 02 are reporting well..
review the video below and ask any questions... it's important you understand fuel trims..

STFT -- short term fuel trims is explained here:

https://www.youtube.com/watch?v=5WnM_NsOtd8
 

·
Registered
Joined
·
182 Posts
Discussion Starter #14
I know this stuff, i just cant write anything because i dont know automotive english very well I have removed rear o2 sensors with catalyst

I am going to send smoke in my engine and see it there is a leak


thanks for your help
 

·
Registered
Joined
·
2,846 Posts
try babblefish or google translations..

so if you know what trims are, what numbers are you getting? run the test that i gave you 12321 for 90.. post the graphs if you can..
 

·
Registered
Joined
·
2,998 Posts
Thought about this thread yesterday. Started it up in the morning the display showed 31 miles range, which was considerably shorter than the range when I parked it.

After getting it warmed up, getting down the 4 miles of side streets and getting about another 4 miles down the highway at cruising speed, the display showed I had a 51 miles range. Our computer looks at all the engine parameters, including auto speed, gas in the tank and computes range based on all those factors. Most only look at fuel in the tank and compute a range based on average recent mpg.

Our computer in typical German style, tries to be extremely accurate, and in doing so, shows what appears to us to be odd numbers. To the computer it makes perfect sense, a cold, rich engine will have a much different range on the same fuel available than will a warm motor in cruise mode.

Jim
 

·
Registered
Joined
·
167 Posts
I have had the same problem. What I found is: The mileage left, is a reflection of your driving at that time, updated bout every minute. When you start it in the morning, the act of starting it uses more fuel than the driving you were doing last night, as does driving it slowly out of your neighborhood warming it up. Also had upon occasion, the last 20 miles to empty or so, drop really, really fast on the, "miles left" reading. Not fun when you are quite a ways out of town with no gas station in sight.

Solution: Don't let the car get real low on fuel, it will be lower in the morning than it seemed when you finished driving it last night. I've taken to not letting my car get much below 1/4. An added benefit, your less likely to suck up crud from the bottom of the tank, like it does when you let it get real low on gas.

Jim
Jim,when i bought my 528i the kid didn't have hardly any gas in it.I filled it up.three days later I got a hesitation and a SES.miss on 5.(O'reillys)..I kept it full of the amoco premium at every chance I got.The SES and missing quit about 500 miles later.Whether this was it is open for debate,cause the Alt. went out soon also.5,000 miles later ..drives and runs like new,for now,lol..:)
 
1 - 17 of 17 Posts
Top