BimmerFest BMW Forum banner

Fuel pressure regulator

7948 Views 6 Replies 4 Participants Last post by  GoForthFast
I have a 99 BMW 328i , and I changed my fuel pressure regulator, and now I have problems starting my car, I have to pump gas with the gas pedal to be able to start my vehicle, I pump just a couple times and is ready to go, please help.
1 - 7 of 7 Posts
Pumping the gas pedal of a fuel injected car does nothing. If you stick your foot to the floor and leave it there while trying to start it will help.

Sounds like you may or may not have done it correctly. Are you sure you got all the connections made correctly?
I changed fuel filter, spark plugs, and cleaned o2 sensors. also it has a new fuel pressure regulaor. Yesterday rented a fuel pressure reader kit, and i check fuel presure, and I notice that gauge go up to 60 psi whenkey is in the on position, and drops down to 0. I also tryed with the car running holding 60 psi, but when i turn off, goes down to 0 again. also i notice when car is running and i press the gas pedal i see no difference in the gauge, no going up or down, problably just 1 psi or 2, no more. also when car idle it go down 1 or 2 psi from 60 psi.
How do you clean O2 sensors? They can't be cleaned.

I had leaky fuel injectors on my car which leaked fuel into the cylinders when the car sat. Dilutes the oil and causes rough starting.
Replaced fuel injectors (6) and all is cured now.

Does your car smell like gas after you get it started?
since you are not holding pressure and just did all that fuel work it sounds like you left a fuel hose clamp loose or did not seat/seal your pressure regulator correctly.

It is also possible you honked up your O2 sensors since they are not supposed to be cleaned, just replaced every 100k or when they go bad.
I changed fuel filter, spark plugs, and cleaned o2 sensors. also it has a new fuel pressure regulaor. Yesterday rented a fuel pressure reader kit, and i check fuel presure, and I notice that gauge go up to 60 psi whenkey is in the on position, and drops down to 0. I also tryed with the car running holding 60 psi, but when i turn off, goes down to 0 again. also i notice when car is running and i press the gas pedal i see no difference in the gauge, no going up or down, problably just 1 psi or 2, no more. also when car idle it go down 1 or 2 psi from 60 psi.
yes you can clean the 02 sensors with throuttle body cleaner,but make sure it say is good for 02 sensors. i dont think is the fuel injectors , but im going to take a look. im thinking it may be the fuel check valve in the fuel pump, which is letting fuel go back in the the tank. also i think i may have a problem with the vacuum line going to the fuel pressure regulator, any one here has a diagram of the vacuum lines on it 99 bmw 328i?
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top