BimmerFest BMW Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have just bought a BMW 645 conv and after replacing the battery I notice that the Fuse number 75 is missing , however on the fuse diagram it shows that it needs to be a Green 30 Fuse in there. Is that right? what is this fuse for? i have also noticed that is water gathering in under battery after a drive in the rain. The boot is all dry!!! where is the water coming from. I nearly pulled my hair out as cant find the leak source! Many thanks for any help . :dunno:
 

·
Michael
Joined
·
2,516 Posts
Fuse

The fuse should be a 30amp fuse. For models upto 2005-09 it is used for the control unit/transfer box. In later models the fuse has a completely different use. My view is that this fuse should not have been removed and maybe hiding a problem. Replace it and see what happens?????
As for the water ingress, can you see a water trail ? is the bung on the underside of the car missing?? water maybe getting in behind the boot carpets so you think it is dry but underneath it is not....... Ultimately you may have to disconnect and remove the battery to see ??????
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
sorted..

After a lot of research , I had a email from BMW , in German!!! The fuse 75 is only for manual versions of E63 and E64 and not for the auto ones like mine. I hope this helps others.:rofl:
 

·
Registered
Joined
·
3,646 Posts
..and the water was coming through the plastic cover in the boot, that had to be changed ....
Do you have a picture or any more details on the cover that was leaking? I've checked my drain plugs but would like to make sure any other areas that leak are in good shape.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top