BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I want to apologize right up front for my lack of knowledge on this question.

I have a 87 325is. Pretty clean, but some things are needing attention as can be expected. 2 years ago the speedometer stopped working periodically. I took it to an authorized BMW repair shop. $$$ They replaced the speedometer 2 times until they finally got one that would work.. Once getting it back, one of the dash lights went bad. Several months later, the speedometer was showing periodic signs of working and not working..

I called Pelican Parts and was told that my SI board batteries were probably bad and I should not replace the battery but the whold unit.. OK.. Ordered installed. Once I got the car back the gas guage was off. They adjusted and is working OK. Now the speedometer works but the Tach and the Temp guage are not working at all. ? They told me that this was very difficult to fix and could take lots of $$$..

I did do a search and found that on certain years there are different gauge clusters..

Motometer and VDO ? What is the difference and what is the proper cluster for my car?

The BMW repair shop said that the board that the guage slides into sometime cracks and that could be the problem as well.

Any help would be greatly appreciated..
 

·
Registered
E92 07 328xi, 04 F350 6.0, 92 Jetta Carat
Joined
·
2,507 Posts
one has a different red line then the other if i remember right. dont deal much with the older e30's as far as clusters...as long as you match up tach with the cluster you want to buy you are good to go.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top