BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I had my car 650 coupe detailed and when I left, I noticed that I had no turn signals. I pulled over and found that the hazards still worked but no turn signals(either momentary or continuous). I brought the car home, pulled in the driveway and now the signals are back! Now before everyone says voilà, the left and right temporary(lane change) signals work fine. If you move the selector past the friction point(continuous) they still only blink 3 times and shut off. It's crazy I tell you! I have played with hazards on and off, turned the 3x flash off an on in iDrive.

How do I get rid of my ghost?
 

·
Registered
Joined
·
2,023 Posts
Strange indeed. Well, I would try removing the turn signal settings in the iDrive (where you select it for the momentary option) Then see if the regular turn signals work. Then go ahead and re-enable that option again. Might just be a glitch.
 

·
Registered
Joined
·
3,646 Posts
If I had to guess this is what I think happened:

1) turn signal stalk was soaked by cleaner during the detail
2) this caused the two micro-switches inside the talk to stop working
3) hazard switch is separate from turn signals so those still work
4) as the cleaning fluid dried out the micro-switch for "3 blink" started working
5) the micro-switch for "constant blinking" is still wet and not working

Hopefully the "constant blinking" will return after the switch dries out. If not, you might be able to open up the turn stalk and clean out the switch your self. This requires removing the steering wheel and the steering column trim. If you are not up to pulling the wheel then a new turn signal stalk costs about $100. Not sure about the labor.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Fingers crossed :)
 

·
Nerdy G
Joined
·
908 Posts
fingers crossed for you sounds like a silly way to spend a few hundred bucks
 

·
Sejanus
Joined
·
5,785 Posts
If I had to guess this is what I think happened:

1) turn signal stalk was soaked by cleaner during the detail
2) this caused the two micro-switches inside the talk to stop working
3) hazard switch is separate from turn signals so those still work
4) as the cleaning fluid dried out the micro-switch for "3 blink" started working
5) the micro-switch for "constant blinking" is still wet and not working

Hopefully the "constant blinking" will return after the switch dries out. If not, you might be able to open up the turn stalk and clean out the switch your self. This requires removing the steering wheel and the steering column trim. If you are not up to pulling the wheel then a new turn signal stalk costs about $100. Not sure about the labor.
Yorgi,
You're like that old "EF Hutton" commercial, when you talk people listen. I always leave your posts feeling like I've learned something!:thumbup: Thanks!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Yorgi. You must have sent good vibes my way. Everything is working great. Waited about 3 days and all is well
 
1 - 7 of 7 Posts
Top