BimmerFest BMW Forum banner
1 - 13 of 13 Posts

· My ride is my glide
Joined
·
1,330 Posts
Discussion Starter · #1 · (Edited)
Have you retro-fitted the facelift IHKA? :dunno:

If you have retro-fitted the facelift IHKA there is a necessary wiring change that needs to be done also.

If you do not do the wiring change, you will have permanently disabled a function of the A/C.

If you have this sorted already, excellent.....

if not....

Video and write up coming shortly.

Ace :typing:
 

· Registered
Joined
·
838 Posts
Hey ACE,

Thanks for the heads up! You referring to the AUC sensor?

Stuart
 

· My ride is my glide
Joined
·
1,330 Posts
Discussion Starter · #3 · (Edited)
Hi Stewey :wave: ...... yeah. With the facelift IHKA it is disabled because it does not supply the power, ground or heat signal data line to the AUC anymore. You have to connect to the CAS and X492 now ...... plus you need to update the AUC.

I have completed the video and I am just doing a write up on it now.... wont be long and it will be up......

PS. I think I can put that stuff in a small padded bag btw .... :eeps:

Ace :typing:
 

· Registered
Joined
·
838 Posts
Hi ACE,

It gets is power from the CAS now? They change stuff just for the sake of it!

Ok, sounds good, let me know how much I owe you.

Many thanks

Stuart
 

· My ride is my glide
Joined
·
1,330 Posts
Discussion Starter · #5 · (Edited)
Hi Stew,

unfortunately, it is a bit more of a complex change than just a change for the sake of it....... although I agree with you, sometimes it would appear that things are changed just for the sake of it......... but not this change :yikes:

The pre-facelift IHKA supplied power and the return ground connection plus it also sent a 'heat' signal (data line) to the AUC.

With the facelift IHKA, they removed the power supply, heat signal (data line) and the return ground connection. So those pins are now dead on the facelift IHKA....... I have tested them and they are definately dead. I had to dust off the CRO to check the data line :rolleyes:

I came across this because I noticed my AUC was not working :yikes:

They redesigned the AUC and it now runs a different signal from the CAS. The original AUC was 4 pin and the facelift AUC is 3 pin.

The only solution is to update the AUC, and modify the wiring.

The return signal (data line) to the IHKA is different too.

I have done it and now I have working AUC again :clap:

I am completing the write up.

Ace :typing:
 

· Registered
Joined
·
838 Posts
I understand, I mean BMW changing things for the sake of it! Is the new sensor better than the old one? Who knows! I'm sure they do it to catch people like us out!

Yeah I noticed on the connector pinouts that they are 'not used' on the new IHKA and did wonder if they were lying! You have proved they aren't!

Glad to know thou Ace, thanks for pointing that out!

Stuart
 

· My ride is my glide
Joined
·
1,330 Posts
Discussion Starter · #7 ·
Hi Stew,

It's a new improved AUC compared to the old AUC .......... anyway, I'm tired now (it's nearly midnight) :snooze: so I will finish this in the morning when I get up

Ace :snooze:
 

· Registered
Joined
·
838 Posts
How much does this facelift cost. Noone ever tells the prices. What all do i need
It all depends how far you want to go. Also most parts on eBay so depends how much you can get it for, bidding, best offer etc...

For example I paid the following:
Facelift MMI = £120
Bluetooth TCU = £70
IHKA = £45
Light Switch = £20
CAS trim = £15
Dash trim for passenger (new dealer part) = £20
NAVI03 = £250
iPod genuine BMW kit = £140

Total approx £680 or $1000 USD.

All of this I upgraded over a 10 month period, buying bits as and when they come up, hardest bit to get is the facelift MMI, they can be hard to come by.

I have not upgraded the ASK, I doubt I will to be honest.

Stuart
 

· Registered
Joined
·
427 Posts
I know this is an old thread but I just did the FL IHKA upgrade on my car and discovered a fix for the AUC issue that I didn't see mentioned anywhere.

After the upgrade I pulled my error codes and saw that I was getting the 9C64 AUC sensor error that I think Ace and Stewart were referring to here. I tried to clear it with no luck.

This tread mentions that the only way to fix it is to rewire the new style AUC sensor.

I did a bit if digging the with NCSExpert/NCSDummy and found a setting that can be updated for pre 03/2005 AUC sensor. My new IHKA is running IHKA_E65.C05 software. The parameter is called AUC_SENSOR and the settings available are auc1 (!KLIMA_HIGH), auc2 (KLIMA_HIGH+!MAERZ05), and auc2mk4 (KLIMA_HIGH+MAERZ05). The unit I received was set to auc2mk4 which is for the post March 05 AUC sensor (MAERZ is German for March) so I just changed the parameter to auc2, coded the new setting to the IHKA, reset the error and all is good now.

Hope this kelps someone else out by avoiding the cost and pain of upgrading the AUC sensor.
 

· CRISP & CLEAN
Joined
·
4,718 Posts
I know this is an old thread but I just did the FL IHKA upgrade on my car and discovered a fix for the AUC issue that I didn't see mentioned anywhere.

After the upgrade I pulled my error codes and saw that I was getting the 9C64 AUC sensor error that I think Ace and Stewart were referring to here. I tried to clear it with no luck.

This tread mentions that the only way to fix it is to rewire the new style AUC sensor.

I did a bit if digging the with NCSExpert/NCSDummy and found a setting that can be updated for pre 03/2005 AUC sensor. My new IHKA is running IHKA_E65.C05 software. The parameter is called AUC_SENSOR and the settings available are auc1 (!KLIMA_HIGH), auc2 (KLIMA_HIGH+!MAERZ05), and auc2mk4 (KLIMA_HIGH+MAERZ05). The unit I received was set to auc2mk4 which is for the post March 05 AUC sensor (MAERZ is German for March) so I just changed the parameter to auc2, coded the new setting to the IHKA, reset the error and all is good now.

Hope this kelps someone else out by avoiding the cost and pain of upgrading the AUC sensor.
I think this was mentioned someplace before , Then the topic was removed or something .
I just did a search but couldn't find it .
 

· Registered
Joined
·
47 Posts
Hi Stew,

unfortunately, it is a bit more of a complex change than just a change for the sake of it....... although I agree with you, sometimes it would appear that things are changed just for the sake of it......... but not this change :yikes:

The pre-facelift IHKA supplied power and the return ground connection plus it also sent a 'heat' signal (data line) to the AUC.

With the facelift IHKA, they removed the power supply, heat signal (data line) and the return ground connection. So those pins are now dead on the facelift IHKA....... I have tested them and they are definately dead. I had to dust off the CRO to check the data line :rolleyes:

I came across this because I noticed my AUC was not working :yikes:

They redesigned the AUC and it now runs a different signal from the CAS. The original AUC was 4 pin and the facelift AUC is 3 pin.

The only solution is to update the AUC, and modify the wiring.

The return signal (data line) to the IHKA is different too.

I have done it and now I have working AUC again :clap:

I am completing the write up.

Ace :typing:
Hi Ace,

Did you make a write up for retrofitting the IHKA?
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top