BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi ,just got a 97 740Il and was looking quite forward to a few minor repairs and then on the road!
Well that went all to pieces,purchased a new battery and while I was away from the shop
an employee was good enough to try and help out by installing it for me,well he hooked the cables up backwards and strange things occured there after. The lights flashed,the sunroof opened ,the cables got real hot and something under the hood didnt smell real good.
The car still starts and runs but the alarm will not shut off and i cannot tell yet any other issues as this is very loud and painful.
Any suggestions on what to do / what could possibly be fried by the cables being hooked up wrong and how am i able to stop the alarm?
Thanks for any help
 

·
Retired Official Welcomer
2018 M4 Competition Package•2019 540i MSport
Joined
·
8,363 Posts
Welcome aboard. :hi: You have been officially welcomed to The 'Fest. :thumbup: I see that you posted your question in the 7er forum. You should get a response soon.
 

·
Dragon Master of TEXAS!
Joined
·
876 Posts
Welcome to the 'FEST! Sorry to hear that a helpful employee did not know what was positive and negative terminals are on a battery! DUH!
Hope the owners on the 7-series board was able to help you.
If not, try contacting one of the owners in your local BMWCCA chapter, they may know someone that will know that answer. Good luck!
 
1 - 3 of 3 Posts
Top