BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So, I found an old burned down 🔥2008 BMW 528xi to restore.

However, I am stuck on getting it to the diagnostics mode. The dash is showing the dreaded "Red Car-Lift of Death". ☠ Pressing the engine start stop button 3 times doesn't have any effect. I've checked the fuses several times all good. Not sure why it's not letting me in. Tried using a different ECU and body module combo same issue. Continuity tested the analog lines with a volt meter looks good. Bit puzzled why it won't let me in to the ACC mode while flashing car on lift at me. Even if the key is unpaired or missing it shouldn't block me from diagnostics as that's how one pares new keys anyway... Would it?

I'm stuck.

There is power on OBD but without going into ACC I really can't pull any codes. 😥
 

·
D'oh, You Kids!
1984 633CSi, 1985 635CSi, 1985 325e, 1987 325is, 1993 325is, 1995 318is, 1995 M3, 2003 F150
Joined
·
30,749 Posts
Welcome to Bimmerfest!

I moved your posting to the E60/E61 forum (5 Series, 2004-2010) so you can get model-specific help.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Welcome to Bimmerfest!

I moved your posting to the E60/E61 forum (5 Series, 2004-2010) so you can get model-specific help.
Thanks 😊. Hope it gets more traction there, though I don't think 🤔 my problem is model specific. Probably another security function is impeding my progress with restoration of this vehicle. But that's just my crazy talking. If someone comes in to a car does all the work to swap all the control modules just to steal the car. They can take it it's worth the insurance clame at that point.

In the meantime I got my hands on by directional diagnosis unit. Can't say that it's much use without the car going into ACC Diagnostics mode, but it's just another way to attack this problem.

Will post it on this thread if I find out what's wrong.
 
1 - 3 of 3 Posts
Top