BimmerFest BMW Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Im new in here! Maisam 2nd owner of the princess E34 1991 wich makes my hair becoming white :mad: .

i got my e34 7 months ago from the previews owner after he lefts it for more than 1 year out of run.
starting with ac instll i make the first step to fix repair needed.(battery,fuel filter,oil and engine filter,belts,air filter,alternator,shock absorber)

The car was running fine until one day when i start the car going to work the acceleration was not normal as i knew,and here the big trouble starts again :tsk:

while accelerating smoothly in a very slow way, the transmission from 1st speed to 2nd is mostly nod that bad but accelerate normal way or little more thats gonna take time to shift from 1st to 2nd speed with a loud sound and sometimes depends on my acceleration the message of TRANS PROGRAM will shows. :bawling:

i asked some mechanics about it unfortunately i ve got many defferent answers.
(fuel pump,gear box oil filter, gear box it self,reprogram the car,speed sensor...
of corse im not gonna make all this ,that will cost me amount of another car as it does already.
i really love my car so much,and im taking more then a good care of it.

The registration is gonna be xpired by the 05/05/2011 and im worried if it will not pass.

Does any one have ideas or advises for?

Note that i had never change gear oil or filter...:confused:

sorry guys i fogot something my car trasmission is AUTOMATIC
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top