BimmerFest BMW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 330 xi that runs ok most of the time but then out of no where the car shudders. It was suggested that I replace the plugs & coil pack & do a top end clean.

I did the above and used OE parts. Now the check engine light is on and the car has multiple misfires. As I said the coils & plugs were just replaced.

Any suggestions?
 

·
Registered
Joined
·
1,908 Posts
You are blindly throwing parts at a problem. Get the codes read and you will likely be much better informed as to what is wrong.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
today the codes are p0300- multiple misfire, p1349-#4 misfire & p1343-#1 misfire.

Yesterday the codes were multiple & #5 misfire. Those showed up after the minor tune up and fuel injection cleaning.

The car never had the plugs replaced so I am not just throwing parts at it.
 

·
Registered
Joined
·
373 Posts
today the codes are p0300- multiple misfire, p1349-#4 misfire & p1343-#1 misfire.

Yesterday the codes were multiple & #5 misfire. Those showed up after the minor tune up and fuel injection cleaning.

The car never had the plugs replaced so I am not just throwing parts at it.
Just to get some clarification. Did the engine shuddering problems seem to pop when you had the service work done (tune up and fuel injection cleaning ), or did they exist beforehand?
 

·
Registered
Joined
·
1,908 Posts
How many miles? Plugs are good for 100K (easily). Sounds like something that is common to all cylinders such as vacuum leak or MAF. There is an elbow on the intake system after the MAF that frequently cracks. It's kinda on the underside of the air intake plumbing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6 (Edited)
The shuddering was happening prior to the tune up. Very intermittent though.

Also had the engine smoke tested and no vaccuum leaks. Mass air sensor was also cleaned with top end service.

It has 80K on it.
 

·
Registered
Joined
·
275 Posts
I had misfire on #3, changed plugs, and ignition coil, problem solved. Mine occured rather suddenly with the misfire and shudder. I had the codes read within 10 min of the occurance. I was just by the autozone, so got it done quickly.
 

·
Registered
Joined
·
1,908 Posts
I had misfire on #3, changed plugs, and ignition coil, problem solved. Mine occured rather suddenly with the misfire and shudder. I had the codes read within 10 min of the occurance. I was just by the autozone, so got it done quickly.
Yes but in Bobo's case the misfire is moving around thus is likely NOT the coil/plugs.

Try disconnecting the MAF and see if the problem goes away. Maybe time to start looking at fuel delivery.
 

·
Seek to understand,^Value
Joined
·
25,199 Posts
We have a similar problem over in the E39 forums and are trying to come up with a debugging sequence for when the fuel cuts off during a cold start where the engine shudders excessively, but the next start 30 seconds later is smooth as silk.
 

·
Registered
Joined
·
438 Posts
I have a 330 xi that runs ok most of the time but then out of no where the car shudders. It was suggested that I replace the plugs & coil pack & do a top end clean.

I did the above and used OE parts. Now the check engine light is on and the car has multiple misfires. As I said the coils & plugs were just replaced.

Any suggestions?
In order for us to try and help you you are going to have to provide some more information. i.e.

* When does the "shudder" happen? (Moving, Stationary, only after having driven for a while, etc)
* Where does it feel like the "Shudder" is coming from? Engine, Driveline, Front, back) etc.
* Any other information as to what you are doing when this happens
*
 
1 - 10 of 10 Posts
Top