BimmerFest BMW Forum banner

Help - AC & blower issues

1550 Views 11 Replies 5 Participants Last post by  atobe
First: very nice and helpful forum + community!!! Congratulations!

Second: I'm really new to forum/bmw. I am a bit of DYI but not as mechanic :(

The story: I always wanted to have a BMW (not new, can't afford) and a friend of mine, mechanic, helped me to get a cheap one, so I got this 2003 525i that was light hit in the front. He changed radiator, fan, spoiler, front light and now it is running, I'm happy with it, except for the ac/blower unit: the original Receiver drier to evaporator hose was broken and since he had some parts from an older 1998 528i he decided to replace that hose, of course the connections to the drier did not fit, so in the process he replaced the receiver drier as well. That's how I got the car and the AC was not working, everything else in the HVAC seemed fine.
At that time (after reading here in the forum) I decided to buy an original OEM hose and put it back along with the original drier hoping to fix the AC problem, but never got there because I noticed there is a humming noise coming out of the A/C Control Push Button Unit (HVAC) when key is out! I disconnected the battery and when reconnect I can see there is some discharge going on. On top of that, last night after parking and keys out I noticed that the blower will start about every 30 seconds, accelerate slowly and after about 5 seconds of blowing will stop and after about 30 seconds will go again... so I ended up removing fuse #9 meanwhile.
At this time, after reading and searching in this forum I'm set to replace the Final Stage Unit/FSU (with the one from 528i :) since I found out they are the same parts) and hopefully I will get rid of the uncontrolled blower issue, not sure if this will fix the AC as well, but if anyone is able to give me some hints, ideas they will be greatly appreciated.

My HVAC looks like this one but the original radio was replaced with an aftermarket mp3 player.
Dang, now I see there is a "sampling fan" in the HVAC, I think that's the noise I hear and that thing is running at all times...

Thank you!
1 - 12 of 12 Posts
www.540i6.com

they all do that "FSU" try that first.
I assume there is no relation between FSU and AC?
I mean a bad/acting FSU cannot "kill" AC, right?

Thank you!
fsu just controls blower speed

but if defective it can cause current drain and kill battery . Is you exterior temp display working? if not that effects yiurAC
fsu just controls blower speed

but if defective it can cause current drain and kill battery . Is you exterior temp display working? if not that effects your AC
I know that and I intend to change it anyway, but I'm trying to figure out if I need to go on an order original OEM part (hose) to try and fix my AC or I should wait until I replace FSU (which may happen tomorrow only).
And yes, exterior sensor temp it is working fine.
OK, I replaced the FSU but AC still not working... :( Fuses are fine, compressor and fan do not start when I engage AC from inside. I noticed that when I connect the drier, both compressor and fan start for about a second then both stop... any ideas what to look for?

Thanks!
is a/c properly charged with right amount of

refrigderant ? BMW systems are very critical for correct weight. Take to AC specialist who does BMWs
Well, until I receive the dryer to evaporator hose I'm starting to find out more and more about the "pleasure of driving and especially owning a BMW":
- had to replace the wipers; I spent almost one hour using inserts (because previous owner glued the wipers to the arms, so i think i will need new arms + wipers)
- had to replace the OEM cup holders because I spilled hot coffee on my privates; (Private Ryan was saved!)
- Two days ago I went and fill up the gas tank; when reached almost full gas started pouring on the opposite side!?! after reading in the forum it looks like I have to take out rear seat and look for some locations where it happens. Meanwhile I enjoy a stinky gas ride until my tank will lower or I fix that thing;
- Last night rained, not very heavy, and this morning I found pools of water in the rear, both sides!?! after reading in the forum I found out that I need to reseal vapor barriers and remove the carpet...
Now, as I said, this is my first BMW and I like the ride, but I think quality build and maintenance is a PITA.

We own two Korean cars as well, one of them 14 years old and the other one 6 years old.
In 14 yrs other than tires, oil, brakes, bulbs and filters, once I forgot driver window open, rained and killed power doors - replaced under warranty, had to replace window motor driver side, this year crankshaft position sensor failed (DIY replaced $75), a hub bearing was noisy and clutch worn out - this was the most expensive repair and of course changing the timing belt twice was also expensive, but other than this AC/heater still works, cup holders are original, no water inside when raining, no gas spill, changing a wiper is done in 30 seconds flat, in other words everything works like 14 years ago and still very reliable! The other one had only one issue with a TPMS sensor, in 6 years (and it is driven by my wife)!

My beemer is 11 yrs old and has only 105k miles on it, the ride is nice and steady, engine seems to run fine and I enjoy driving it, but I can't stop asking myself/guessing what will happen to "my new baby" tomorrow or this weekend!?
Anyone?!?
Im having similar problem . I have 2000 528i and the digital display works fine but there is no air blowing into the cabin. I tried the a/c , the heater and the defrost and none of them blows any air . Any suggestions please.
- How to optimally set up the BMW E39 IHKA air conditioning system (1) & how to set the fan blower speed to preserve your FSU (1) & an explanation of the three heating cooling blue dots (1) & how to eliminate the a/c musty gym sock odor (1) & how to remove the IHKA heater air conditioning control panel to clean the circuit board (1) & how to check the HVAC (IHKA) sampling fan (1) & how to remove the trim and bracket holding the MID (1) & how to remove (for a Hualigan) the E39 dashboard trim (1) & how to diagnose lack of HVAC/IHKA heater core heat with cooling system (auxiliary pump) at idle (1) & how to replace or repair the IHKA button (1) & how to change OBC MID IHKA KTMP temperature from °C Celcius degree to °F Fahrenheit degrees (1) & what is this thing (HVAC/IHKA solar sensor) in the middle of my dashboard by the windshield (1) & how to replace the activated charcoal cabin air filter (1) & what cabin filter to buy (1) & cn90's inexpensive cabin filter retrofit (1) & how to measure A C temperature (1) & where to find your low pressure airconditioning recharge port (1) & how to refill your A/C system for $20 (1) & what refrigerant PAG oil to use (1) & how to diagnose A/C compressor knocking and rattling sounds (1)
Im having similar problem . I have 2000 528i and the digital display works fine but there is no air blowing into the cabin. I tried the a/c , the heater and the defrost and none of them blows any air . Any suggestions please.
So you dragged up a post from 2015 to advertise for general AC service in Singapore ?
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top