BimmerFest BMW Forum banner
1 - 16 of 16 Posts

·
Registered
Automatic, M54, sport package, cold weather package, comfort package
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi! Im starting to have a “panic attack,” not really but am definitely worried since my speedometer is not currently working. I have a 2003 530i. I recently had chewed wires on my headlight wiring harness so I bought a new one on eBay and replaced the whole harness from the box under the hood. The only issue is that harness also was the source of all of the wires to/from by ABS/DSC module. Everything is working fine except I have a “BRAKE” and “ABS” light as well as my Speedo and cruise control not working. At this point the only thing I’m worried about is the speedo. I have already looked through a bunch of forms and threads as well as schematics, I’ve also traced all of my speed sensors including the right rear sensor and re-spliced all of the wires. I’m starting to think it is something in between the ABS module and the cluster but I’m unsure what wires that is. Can anyone help? Pics below. Yes I know it’s sloppy, but it’s the only way I could do it with the resources I have.

Hood Motor vehicle Car Automotive design Automotive exterior
 

·
Registered
Automatic, M54, sport package, cold weather package, comfort package
Joined
·
6 Posts
Discussion Starter · #5 ·
Not trying to be disrespectful but.......OMFG WTAF is that mess?! You need to join those wires with solder and dual wall heat shrink the joins to make them waterproof. What you have there is going to be nothing but continuous trouble, as you have already found out.
I know, I’ve already tried solder and heat shrink twice including solder seal connectors and neither worked as I believe the wires are too old and dirty for solder to stick as they just came apart no matter what I did.
 

·
Radar Specialist
Joined
·
18,942 Posts
I thought I would come into this thread saying change your wheel speed sensor....but boy was I wrong. Good luck finding the cause of the issues you're having. Get a quality soldering gun man
 

·
Registered
‘89 325i, ‘98 528i, ‘99 528i, ‘03 325i
Joined
·
563 Posts
I can weld, braze all day long but my hands are all thumbs and I can’t solder. If I were you I would pay someone to straighten that out. If money is an issue get creative. I fund my BMW problem by cutting grass for the most part, not having a monthly car payment helps a lot too.
 

·
Registered
Joined
·
60 Posts
I know, I’ve already tried solder and heat shrink twice including solder seal connectors and neither worked as I believe the wires are too old and dirty for solder to stick as they just came apart no matter what I did.
If the wires under insulation are not "clean copper", then yeah, solder won't "stick".
You need to:
  • check rear left speed signal, that is the one I believe responsible for speed on the cluster
  • redo all this mess by soldering and using heat shrinks (or pay someone to do it)
  • if the wires are bad, cut/strip them until you get to a nice copper metal. Then replace the bad part of every wire. Make damn sure, you don't mix them.
 

·
Wingnut
Joined
·
5,807 Posts
within reason.. depending on whether theres surface oxidation, or the wires are corroded. flux heats up and boils carrying off contaminants. if the wire is in bad shape, no amount of flux will allow tinning.
 

·
Registered
Automatic, M54, sport package, cold weather package, comfort package
Joined
·
6 Posts
Discussion Starter · #16 ·
Is there possibly anyone who know which wire(s) go from the abs unit, to the can bus that are in relation to the speedometer?
 
1 - 16 of 16 Posts
Top